summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavan Rikhi2018-03-09 03:45:22 -0500
committerPavan Rikhi2018-03-09 03:45:22 -0500
commit3841338bedd155579d34839ed3314a837d06c018 (patch)
tree54dea75a09cbe313056ac549afed396562f1a0b1
downloadaur-3841338bedd155579d34839ed3314a837d06c018.tar.gz
Migrate Package From palemoon-git
-rw-r--r--.SRCINFO47
-rw-r--r--PKGBUILD81
-rw-r--r--mozconfig.in80
-rw-r--r--newmoon.desktop13
-rw-r--r--newmoon.install12
-rw-r--r--rhbz-966424.patch14
6 files changed, 247 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219ab69036aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,47 @@
+# Generated by mksrcinfo v8
+# Fri Mar 9 08:43:47 UTC 2018
+pkgbase = newmoon-git
+ pkgdesc = Open source, unbranded web browser based on Firefox focusing on efficiency (git version)
+ pkgver = 27.9.0a1+e9a220677
+ pkgrel = 1
+ url = http://www.palemoon.org/
+ install = newmoon.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ makedepends = git
+ makedepends = python2
+ makedepends = autoconf2.13
+ makedepends = unzip
+ makedepends = zip
+ makedepends = yasm
+ makedepends = ffmpeg
+ makedepends = libpulse
+ makedepends = gcc5
+ depends = gtk2
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = alsa-lib
+ depends = libevent
+ depends = hunspell
+ depends = startup-notification
+ optdepends = networkmanager: Location detection via available WiFi networks
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = hyphen: library for hyphenation and justification
+ provides = firefox
+ source = git+https://github.com/MoonchildProductions/Pale-Moon
+ source = rhbz-966424.patch
+ source = newmoon.desktop
+ source = mozconfig.in
+ md5sums = SKIP
+ md5sums = 95d212604b6c8354f9e255db5c3ce0ea
+ md5sums = d663992d87725434f02c57814ec24a67
+ md5sums = 261ad3141f2576f2f1884bd1ddf4a64f
+
+pkgname = newmoon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7949c2d672c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: Pavan Rikhi <pavan.rikhi@gmail.com>
+# Forked from palemoon-git PKGBUILD
+pkgname=newmoon-git
+pkgver=27.9.0a1+e9a220677
+pkgrel=1
+pkgdesc="Open source, unbranded web browser based on Firefox focusing on efficiency (git version)"
+arch=('i686' 'x86_64')
+url="http://www.palemoon.org/"
+license=('MPL' 'GPL' 'LGPL')
+depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'alsa-lib' 'libevent' 'hunspell' 'startup-notification')
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libpulse' 'gcc5')
+optdepends=('networkmanager: Location detection via available WiFi networks'
+ 'libpulse: PulseAudio audio driver'
+ 'hyphen: library for hyphenation and justification')
+conflicts=()
+provides=('firefox')
+install=newmoon.install
+source=(git+"https://github.com/MoonchildProductions/Pale-Moon"
+ rhbz-966424.patch
+ newmoon.desktop
+ mozconfig.in)
+md5sums=('SKIP'
+ '95d212604b6c8354f9e255db5c3ce0ea'
+ 'd663992d87725434f02c57814ec24a67'
+ '261ad3141f2576f2f1884bd1ddf4a64f')
+
+pkgver() {
+ cd Pale-Moon
+ echo $(cat browser/config/version.txt)"+"$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ sed 's#%SRCDIR%#'"$srcdir"'#g' mozconfig.in > mozconfig
+ cd Pale-Moon
+
+ chmod -R +x build/autoconf/* python/*
+ find . -name '*.sh' -exec chmod +x {} \;
+}
+
+build() {
+ cd Pale-Moon
+
+ patch -Np0 -i ../rhbz-966424.patch
+
+ export CC=gcc-5
+ export CXX=g++-5
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MOZCONFIG="$srcdir/mozconfig"
+ export CPPFLAGS="$CPPFLAGS -O3 -msse2 -mfpmath=sse -march=native -mtune=native"
+ export LDFLAGS="$LDFLAGS -Wl,-z,norelro,-O3,--sort-common,--as-needed,--relax,-z,combreloc,-z,global,--no-omagic"
+ python2 mach build
+}
+
+package() {
+ cd pmbuild
+ make package
+ cd dist
+ install -d "$pkgdir"/usr/{bin,lib}
+ cp -r palemoon/ "$pkgdir/usr/lib/newmoon"
+ ln -s "../lib/newmoon/palemoon" "$pkgdir/usr/bin/newmoon"
+ install -Dm644 "$srcdir/newmoon.desktop" "$pkgdir/usr/share/applications/newmoon.desktop"
+
+ # icons
+ install -Dm644 palemoon/browser/chrome/icons/default/default16.png \
+ "$pkgdir/usr/share/icons/hicolor/16x16/apps/newmoon.png"
+ install -Dm644 palemoon/browser/chrome/icons/default/default32.png \
+ "$pkgdir/usr/share/icons/hicolor/32x32/apps/newmoon.png"
+ install -Dm644 palemoon/browser/chrome/icons/default/default48.png \
+ "$pkgdir/usr/share/icons/hicolor/48x48/apps/newmoon.png"
+ install -Dm644 palemoon/browser/icons/mozicon128.png \
+ "$pkgdir/usr/share/icons/hicolor/128x128/apps/newmoon.png"
+
+ # use system-provided dictionaries
+ rm -rf "$pkgdir"/usr/lib/newmoon/{dictionaries,hyphenation}
+ ln -s /usr/share/hunspell "$pkgdir/usr/lib/newmoon/dictionaries"
+ ln -s /usr/share/hyphen "$pkgdir/usr/lib/newmoon/hyphenation"
+
+ # avoid duplicate binaries
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ rm -f "$pkgdir/usr/lib/newmoon/palemoon-bin"
+}
diff --git a/mozconfig.in b/mozconfig.in
new file mode 100644
index 000000000000..484fc7e4c8e3
--- /dev/null
+++ b/mozconfig.in
@@ -0,0 +1,80 @@
+# general build setup
+mk_add_options PYTHON=/usr/bin/python2
+
+mk_add_options MOZ_CO_PROJECT=browser
+ac_add_options --enable-application=browser
+
+# number of cores your processor has
+mk_add_options MOZ_MAKE_FLAGS="-j8"
+
+export CC=gcc-5
+export CXX=g++-5
+export CXXFLAGS="-fPIC"
+export CFLAGS="-fPIC"
+
+# let's do some ricing
+ac_add_options --enable-optimize="-O2 -msse2 -mfpmath=sse -march=native -mtune=native"
+
+# strip debugging symbols
+ac_add_options --enable-strip
+
+# library and chrome format
+ac_add_options --enable-chrome-format=omni
+ac_add_options --x-libraries=/usr/lib
+
+# Use System libraries
+#ac_add_options --enable-default-toolkit=cairo-gtk3 # breaks the build, gtk3 support is not ready
+#ac_add_options --with-system-nss # build stops and informs us that system nss is not currently supported
+#ac_add_options --enable-system-cairo # system cairo may result in choppy video playback without layer acceleration
+ac_add_options --with-system-nspr
+ac_add_options --with-system-jpeg
+ac_add_options --with-system-zlib
+ac_add_options --with-system-bz2
+ac_add_options --with-system-png
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
+ac_add_options --with-system-icu
+ac_add_options --with-system-webp
+ac_add_options --enable-system-hunspell
+ac_add_options --enable-system-sqlite
+ac_add_options --enable-system-ffi
+ac_add_options --enable-system-pixman
+ac_add_options --enable-jemalloc
+ac_add_options --with-pthreads
+
+mk_add_options MOZ_CO_PROJECT=browser
+ac_add_options --enable-application=browser
+mk_add_options MOZ_OBJDIR=%SRCDIR%/pmbuild
+
+ac_add_options --enable-shared-js
+ac_add_options --enable-devtools
+
+# Elfhack Breaks Builds
+ac_add_options --disable-elf-hack
+
+# Disable geolocation web services
+ac_add_options --disable-necko-wifi
+
+# Disable webrtc (I think this is actually removed in palemoon)
+ac_add_options --disable-webrtc
+
+# Disable contacting anyone about anything (also removed in palemoon)
+ac_add_options --disable-crashreporter
+ac_add_options --disable-updater
+ac_add_options --disable-tests
+
+# Features
+ac_add_options --enable-startup-notification
+ac_add_options --enable-pulseaudio
+
+# disable stuff we probably don't need or want
+ac_add_options --disable-gamepad
+ac_add_options --disable-logging
+ac_add_options --disable-installer
+ac_add_options --disable-updater
+ac_add_options --disable-websms-backend
+ac_add_options --disable-mobile-optimize
+ac_add_options --disable-codesighs
+ac_add_options --disable-debug
+ac_add_options --disable-debug-symbols
+ac_add_options --disable-codesighs
diff --git a/newmoon.desktop b/newmoon.desktop
new file mode 100644
index 000000000000..6bd2b3a399a2
--- /dev/null
+++ b/newmoon.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=New Moon Web Browser
+Comment=Browse the World Wide Web
+Keywords=Internet;WWW;Browser;Web;Firefox
+Exec=newmoon %u
+Terminal=false
+X-MultipleArgs=false
+Type=Application
+Icon=newmoon
+Categories=Network;WebBrowser;Internet
+MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;
+StartupNotify=true
diff --git a/newmoon.install b/newmoon.install
new file mode 100644
index 000000000000..c929b541c726
--- /dev/null
+++ b/newmoon.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+} \ No newline at end of file
diff --git a/rhbz-966424.patch b/rhbz-966424.patch
new file mode 100644
index 000000000000..ebe9ec7ca555
--- /dev/null
+++ b/rhbz-966424.patch
@@ -0,0 +1,14 @@
+diff -up toolkit/modules/CertUtils.jsm toolkit/modules/CertUtils.jsm
+--- toolkit/modules/CertUtils.jsm 2014-10-14 08:12:14.358697255 +0200
++++ toolkit/modules/CertUtils.jsm 2014-10-14 08:17:59.962181908 +0200
+@@ -174,7 +174,9 @@ this.checkCert =
+ }
+
+ function isBuiltinToken(tokenName) {
+- return tokenName == "Builtin Object Token";
++ return tokenName == "Builtin Object Token" ||
++ tokenName == "Default Trust" ||
++ tokenName == "System Trust";
+ }
+
+ /**