summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Finelli2023-04-23 14:10:05 +0200
committerMario Finelli2023-04-23 14:10:05 +0200
commit5fcb191c17f9bbdf5c8936132f29c7f8d8ce8c2d (patch)
tree4b5087ad731091a913ccc211a27ad9069d09f1cf
parent2ffdf4b7b58a504efc28c8cfa87ac4ad7c17cc61 (diff)
downloadaur-5fcb191c17f9bbdf5c8936132f29c7f8d8ce8c2d.tar.gz
upgpkg: newrelic-cli 0.67.4-1
upstream release
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 823152dd163b..da6c56b9f4bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = newrelic-cli
pkgdesc = The New Relic Command Line Interface
- pkgver = 0.67.0
+ pkgver = 0.67.4
pkgrel = 1
url = https://github.com/newrelic/newrelic-cli
arch = x86_64
license = Apache
makedepends = go
- makedepends = git
depends = glibc
- source = git+https://github.com/newrelic/newrelic-cli.git#tag=v0.67.0
- sha256sums = SKIP
+ source = https://github.com/newrelic/newrelic-cli/archive/v0.67.4/newrelic-cli-0.67.4.tar.gz
+ sha256sums = 5dba11ed8f7115b6ac0436037743181d56c142c111ce21e2125d6776d935a86a
pkgname = newrelic-cli
diff --git a/PKGBUILD b/PKGBUILD
index 12a7654e17fd..044c7dee74e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Mario Finelli <mario at finel dot li>
pkgname=newrelic-cli
-pkgver=0.67.0
+pkgver=0.67.4
pkgrel=1
pkgdesc="The New Relic Command Line Interface"
arch=(x86_64)
url=https://github.com/newrelic/newrelic-cli
license=(Apache)
depends=(glibc)
-makedepends=(go git)
-source=(git+https://github.com/newrelic/${pkgname}.git#tag=v${pkgver})
-sha256sums=('SKIP')
+makedepends=(go)
+# source=(git+https://github.com/newrelic/${pkgname}.git#tag=v${pkgver})
+source=(${url}/archive/v${pkgver}/$pkgname-$pkgver.tar.gz)
+sha256sums=('5dba11ed8f7115b6ac0436037743181d56c142c111ce21e2125d6776d935a86a')
prepare() {
- cd newrelic-cli
+ cd $pkgname-$pkgver
export GOPATH="${srcdir}/gopath"
- go mod vendor
+ go mod download
}
build() {
- cd newrelic-cli
+ cd $pkgname-$pkgver
export CGO_LDFLAGS="$LDFLAGS"
export CGO_CFLAGS="$CFLAGS"
@@ -33,18 +34,22 @@ build() {
-trimpath \
-buildmode=pie \
-mod=readonly \
- -ldflags "-s -w -linkmode external -extldflags \"${LDFLAGS}\" -X main.appName=newrelic-cli -X main.version=v${pkgver} -X github.com/newrelic/newrelic-cli/internal/client.version=v${pkgver}" \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" \
+ -X main.appName=newrelic-cli \
+ -X github.com/newrelic/newrelic-vli/internal/cli.version=${pkgver}" \
cmd/newrelic/*
}
package() {
- cd newrelic-cli
+ cd $pkgname-$pkgver
install -Dm0755 bin/newrelic "$pkgdir/usr/bin/newrelic"
"${pkgdir}/usr/bin/newrelic" completion --shell bash | install -Dm0644 \
/dev/stdin "${pkgdir}/usr/share/bash-completion/completions/newrelic"
"${pkgdir}/usr/bin/newrelic" completion --shell zsh | install -Dm0644 \
/dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_newrelic"
+ "${pkgdir}/usr/bin/newrelic" completion --shell fish | install -Dm0644 \
+ /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/newrelic.fish"
}
# vim: set ts=2 sw=2 et: