summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrey Blancher2024-04-12 19:16:15 -0400
committerTrey Blancher2024-04-12 19:16:15 -0400
commitc05762170d7b75c4a2bc2f92d1584edc532e8341 (patch)
tree9b3f276b9df558474e52442e37d0d4d2520097db
downloadaur-c05762170d7b75c4a2bc2f92d1584edc532e8341.tar.gz
Initial commit to AUR
-rw-r--r--.SRCINFO28
-rw-r--r--CHANGELOG3
-rw-r--r--PKGBUILD34
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e133fba1064f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = newrelic-cli-bin
+ pkgdesc = New Relic: All-in-One Observability Service - command line tool
+ pkgver = 0.82.0
+ pkgrel = 1
+ url = https://github.com/newrelic/newrelic-cli/
+ changelog = CHANGELOG
+ arch = aarch64
+ arch = armv7h
+ arch = x86_64
+ groups = newrelic
+ license = Apache
+ provides = newrelic-cli
+ conflicts = newrelic-cli
+ validpgpkeys = 5961D131BB2C5C6B42B14D0F92ADA76A30A3F1FD
+ source_aarch64 = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_arm64.tar.gz
+ source_aarch64 = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_arm64.tar.gz.sig
+ sha256sums_aarch64 = 704ccbb89eb2cad58fe096d49349fbc192777584b28c7c68a5fddd3e1263e3f4
+ sha256sums_aarch64 = SKIP
+ source_armv7h = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_armv7.tar.gz
+ source_armv7h = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_armv7.tar.gz.sig
+ sha256sums_armv7h = 51e8fedef30062bfa9d5e818becd2239528f4897d04da7d442d92551a3d5b75a
+ sha256sums_armv7h = SKIP
+ source_x86_64 = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_x86_64.tar.gz
+ source_x86_64 = https://github.com/newrelic/newrelic-cli/releases/download/v0.82.0/newrelic-cli_0.82.0_Linux_x86_64.tar.gz.sig
+ sha256sums_x86_64 = a41649a128357d73089bb75416bb47a1336c62f56e8802f3343f02815aab8ab5
+ sha256sums_x86_64 = SKIP
+
+pkgname = newrelic-cli-bin
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..436e9773a1fb
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,3 @@
+2024-04-12:
+ - version 0.82.0
+ - initial commit to AUR
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a07983e6b47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Trey Blancher $(base64 -d <<< dHJleUBibGFuY2hlci5uZXQK)
+pkgname="newrelic-cli-bin"
+_pkg="${pkgname/-bin/}"
+pkgver=0.82.0
+pkgrel=1
+pkgdesc="New Relic: All-in-One Observability Service - command line tool"
+arch=('aarch64' 'armv7h' 'x86_64')
+url="https://github.com/newrelic/newrelic-cli/"
+license=('Apache')
+groups=('newrelic')
+provides=('newrelic-cli')
+conflicts=('newrelic-cli')
+changelog="CHANGELOG"
+source_aarch64=("https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_arm64.tar.gz"
+ "https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_arm64.tar.gz.sig")
+source_armv7h=("https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_armv7.tar.gz"
+ "https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_armv7.tar.gz.sig")
+source_x86_64=("https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_x86_64.tar.gz"
+ "https://github.com/newrelic/newrelic-cli/releases/download/v${pkgver}/${_pkg}_${pkgver}_Linux_x86_64.tar.gz.sig")
+validpgpkeys=("5961D131BB2C5C6B42B14D0F92ADA76A30A3F1FD")
+
+
+package() {
+ local _exec=${_pkg//-cli/}
+ # Note, newrelic expects to be in /usr/local/bin, newrelic install will
+ # fail if it isn't here
+ install -Dm u=rwx,go=rx -t "${pkgdir}/usr/local/bin/" "${srcdir}/${_exec}"
+}
+sha256sums_aarch64=('704ccbb89eb2cad58fe096d49349fbc192777584b28c7c68a5fddd3e1263e3f4'
+ 'SKIP')
+sha256sums_armv7h=('51e8fedef30062bfa9d5e818becd2239528f4897d04da7d442d92551a3d5b75a'
+ 'SKIP')
+sha256sums_x86_64=('a41649a128357d73089bb75416bb47a1336c62f56e8802f3343f02815aab8ab5'
+ 'SKIP')