summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrey Blancher2024-04-12 18:58:50 -0400
committerTrey Blancher2024-04-12 18:58:50 -0400
commit6a55272b74c9d9418e0a7876eef924e4bc16bdd9 (patch)
treedd30803e1dbe9d7f2e1edb0da54815cc88814fde
downloadaur-6a55272b74c9d9418e0a7876eef924e4bc16bdd9.tar.gz
Fixed typo in pkgrel
-rw-r--r--.SRCINFO31
-rw-r--r--CHANGELOG3
-rw-r--r--PKGBUILD39
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27e4ca532482
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = newrelic-infra-bin
+ pkgdesc = New Relic - All-in-On Observability - infrastructure agent
+ pkgver = 1.52.0
+ pkgrel = 2
+ url = https://github.com/newrelic/infrastructure-agent/
+ changelog = CHANGELOG
+ arch = aarch64
+ arch = armv7h
+ arch = x86_64
+ groups = newrelic
+ license = Apache
+ provides = newrelic-infra
+ conflicts = newrelic-infra
+ backup = etc/newrelic-infra/newrelic-infra.yml
+ source = https://raw.githubusercontent.com/newrelic/infrastructure-agent/master/assets/examples/infrastructure/newrelic-infra-template.yml.example
+ validpgpkeys = A758B3FBCD43BE8D123A3476BB29EE038ECCE87C
+ sha256sums = 60f2a31b2d461f029c786a18f1feb393c1a5e43beac520b1c7d5e12b45590ae0
+ source_aarch64 = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_arm64.tar.gz
+ source_aarch64 = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_arm64.tar.gz.asc
+ sha256sums_aarch64 = 78cf29b2df7468cf3782141cd12c15e39144f4c87d440156ce2168017a223e7b
+ sha256sums_aarch64 = SKIP
+ source_armv7h = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_arm.tar.gz
+ source_armv7h = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_arm.tar.gz.asc
+ sha256sums_armv7h = 396fa7fd8732843c9b545799db905d6050cb19ed9dff4ae04a54194fa4da8c84
+ sha256sums_armv7h = SKIP
+ source_x86_64 = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_amd64.tar.gz
+ source_x86_64 = https://github.com/newrelic/infrastructure-agent/releases/download/1.52.0/newrelic-infra_linux_1.52.0_amd64.tar.gz.asc
+ sha256sums_x86_64 = 68e64efd76f812f079022ae1bcef32196725cfc4dff4a4bae18f7d79a9b62145
+ sha256sums_x86_64 = SKIP
+
+pkgname = newrelic-infra-bin
diff --git a/CHANGELOG b/CHANGELOG
new file mode 100644
index 000000000000..15280ab3fef3
--- /dev/null
+++ b/CHANGELOG
@@ -0,0 +1,3 @@
+2024-04-12
+ - version 1.52.0
+ - initial submission to AUR
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b748ecacd60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Trey Blancher $(base64 -d <<< dHJleUBibGFuY2hlci5uZXQK)
+pkgname=newrelic-infra-bin
+_pkg=${pkgname//-bin/}
+pkgver=1.52.0
+pkgrel=1
+pkgdesc="New Relic - All-in-On Observability - infrastructure agent"
+arch=('aarch64' 'armv7h' 'x86_64')
+url="https://github.com/newrelic/infrastructure-agent/"
+license=('Apache')
+groups=('newrelic')
+provides=('newrelic-infra')
+conflicts=('newrelic-infra')
+changelog="CHANGELOG"
+backup=('etc/newrelic-infra/newrelic-infra.yml')
+source=('https://raw.githubusercontent.com/newrelic/infrastructure-agent/master/assets/examples/infrastructure/newrelic-infra-template.yml.example')
+source_aarch64=("https://github.com/newrelic/infrastructure-agent/releases/download/${pkgver}/${_pkg}_linux_${pkgver}_arm64.tar.gz"{,.asc})
+source_armv7h=("https://github.com/newrelic/infrastructure-agent/releases/download/${pkgver}/${_pkg}_linux_${pkgver}_arm.tar.gz"{,.asc})
+source_x86_64=("https://github.com/newrelic/infrastructure-agent/releases/download/${pkgver}/${_pkg}_linux_${pkgver}_amd64.tar.gz"{,.asc})
+validpgpkeys=('A758B3FBCD43BE8D123A3476BB29EE038ECCE87C')
+
+package() {
+ # create destination directories
+ mkdir -p ${pkgdir}/etc/${_pkg}
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/lib/systemd/system/
+ mkdir -p ${pkgdir}/var/db/${_pkg}/{custom-integrations,integrations.d,newrelic-integrations}
+
+ install -m u=rw,go=r ${srcdir}/${_pkg}-template.yml.example ${pkgdir}/etc/${_pkg}/${_pkg}.yml
+ install -m u=rw,go=r ${srcdir}/${_pkg}/etc/init_scripts/systemd/${_pkg}.service ${pkgdir}/usr/lib/systemd/system/
+ install -m u=rwx,go=rx ${srcdir}/${_pkg}/usr/bin/* ${pkgdir}/usr/bin/
+ install -m u=rw,go=r ${srcdir}/${_pkg}/var/db/${_pkg}/LICENSE.txt ${pkgdir}/var/db/${_pkg}/
+}
+sha256sums=('60f2a31b2d461f029c786a18f1feb393c1a5e43beac520b1c7d5e12b45590ae0')
+sha256sums_aarch64=('78cf29b2df7468cf3782141cd12c15e39144f4c87d440156ce2168017a223e7b'
+ 'SKIP')
+sha256sums_armv7h=('396fa7fd8732843c9b545799db905d6050cb19ed9dff4ae04a54194fa4da8c84'
+ 'SKIP')
+sha256sums_x86_64=('68e64efd76f812f079022ae1bcef32196725cfc4dff4a4bae18f7d79a9b62145'
+ 'SKIP')