summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Gabaldon2023-11-26 16:51:16 +0100
committerIvan Gabaldon2023-11-26 16:51:16 +0100
commit8943ea5f543ffc625d1e1e0a5710ae8664eaa01e (patch)
tree5efa84664f137dd45e88857d5e1272c57f0902f4
parent6b385c1309b07bf4c6d4104175ce615bdaad66c5 (diff)
downloadaur-newrelic-php5.tar.gz
upgpkg: newrelic-php5 10.14.0.3-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
-rwxr-xr-xnewrelic-php5.install21
3 files changed, 25 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b625edbd9db4..63f020ca29c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = newrelic-php5
pkgdesc = PHP Monitoring Agent
- pkgver = 10.9.0.324
+ pkgver = 10.14.0.3
pkgrel = 1
url = https://newrelic.com/php
install = newrelic-php5.install
+ arch = aarch64
arch = x86_64
license = Apache
depends = php
- noextract = newrelic-php5-10.9.0.324.tar.gz
+ noextract = newrelic-php5-10.14.0.3.tar.gz
backup = etc/php/conf.d/newrelic.ini
- source = newrelic-php5-10.9.0.324.tar.gz::https://download.newrelic.com/php_agent/archive/10.9.0.324/newrelic-php5-10.9.0.324-linux.tar.gz
- b2sums = aff4c634414cd8acd6588d92bea998b7d6b556fa4d6d208df0118180630e04387ca3da0b0af071b7099f15c282a64e04693c7831369d41da7462bd3f75ae49e2
+ source = newrelic-php5-10.14.0.3.tar.gz::https://download.newrelic.com/php_agent/archive/10.14.0.3/newrelic-php5-10.14.0.3-linux.tar.gz
+ b2sums = b0d567306ad785afec272aa72fcc96ae8d5abdf58f59337a88a9d49fbd0c9ab18a653f5ac94ffe54332b9a48cf54ac7c864c5cecc1bcc0f952968907994e2444
pkgname = newrelic-php5
diff --git a/PKGBUILD b/PKGBUILD
index 30fdac33e585..b5597679b77a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
-# Maintainer: Ivan Gabaldon <aur[at]inetol[dot]net>
+# Maintainer: Ivan Gabaldon <aur[at]inetol.net>
# Contributor: Kim Brandt <myrveln@gmail.com>
# Contributor: Vinh Nguyen <kurei [at] axcoto.com>
# Contributor: Felix Yan <felixonmars@archlinux.org>
pkgname=newrelic-php5
-pkgver=10.9.0.324
-_libver=20210902
+pkgver=10.14.0.3
pkgrel=1
pkgdesc='PHP Monitoring Agent'
-arch=('x86_64')
+arch=('aarch64' 'x86_64')
url='https://newrelic.com/php'
license=('Apache')
depends=('php')
@@ -16,7 +15,7 @@ backup=('etc/php/conf.d/newrelic.ini')
install="$pkgname.install"
source=("$pkgname-$pkgver.tar.gz::https://download.newrelic.com/php_agent/archive/$pkgver/$pkgname-$pkgver-linux.tar.gz")
noextract=("$pkgname-$pkgver.tar.gz")
-b2sums=('aff4c634414cd8acd6588d92bea998b7d6b556fa4d6d208df0118180630e04387ca3da0b0af071b7099f15c282a64e04693c7831369d41da7462bd3f75ae49e2')
+b2sums=('b0d567306ad785afec272aa72fcc96ae8d5abdf58f59337a88a9d49fbd0c9ab18a653f5ac94ffe54332b9a48cf54ac7c864c5cecc1bcc0f952968907994e2444')
prepare() {
mkdir -p "$pkgname-$pkgver"
@@ -24,15 +23,18 @@ prepare() {
}
package() {
- install -Dm755 "$srcdir/$pkgname-$pkgver/daemon/newrelic-daemon.x64" "$pkgdir/usr/bin/newrelic-daemon"
+ if [ "$CARCH" == 'aarch64' ]; then
+ install -Dm755 "$srcdir/$pkgname-$pkgver/daemon/newrelic-daemon.aarch64" "$pkgdir/usr/bin/newrelic-daemon"
+ install -Dm755 "$srcdir/$pkgname-$pkgver/agent/aarch64/newrelic-20220829.so" "$pkgdir/usr/lib/php/modules/newrelic.so"
+ else
+ install -Dm755 "$srcdir/$pkgname-$pkgver/daemon/newrelic-daemon.x64" "$pkgdir/usr/bin/newrelic-daemon"
+ install -Dm755 "$srcdir/$pkgname-$pkgver/agent/x64/newrelic-20220829.so" "$pkgdir/usr/lib/php/modules/newrelic.so"
+ fi
- install -Dm755 "$srcdir/$pkgname-$pkgver/agent/x64/newrelic-$_libver-zts.so" "$pkgdir/usr/lib/php/modules/newrelic-zts.so"
- install -Dm755 "$srcdir/$pkgname-$pkgver/agent/x64/newrelic-$_libver.so" "$pkgdir/usr/lib/php/modules/newrelic.so"
-
- install -Dm644 "$srcdir/$pkgname-$pkgver/scripts/newrelic.ini.template" "$pkgdir/etc/php/conf.d/newrelic.ini.template"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/scripts/newrelic.cfg.template" "$pkgdir/etc/newrelic/newrelic.cfg"
install -Dm644 "$srcdir/$pkgname-$pkgver/scripts/newrelic.ini.template" "$pkgdir/etc/php/conf.d/newrelic.ini"
install -Dm644 "$srcdir/$pkgname-$pkgver/scripts/newrelic-daemon.service" "$pkgdir/usr/lib/systemd/system/newrelic-daemon.service"
- install -Dm644 "$srcdir/$pkgname-$pkgver/README.txt" "$pkgdir/usr/share/doc/$pkgname/README"
install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/README.txt" "$pkgdir/usr/share/doc/$pkgname/README"
}
diff --git a/newrelic-php5.install b/newrelic-php5.install
index c3b67aff3ce3..4ada03eebc62 100755
--- a/newrelic-php5.install
+++ b/newrelic-php5.install
@@ -1,34 +1,28 @@
post_install() {
- # Setup "newrelic" user/group
+ # Setup "newrelic"
useradd --system -M --home / --shell /sbin/nologin newrelic || true
# Setup permissions
mkdir -p /var/log/newrelic
chmod 755 /var/log/newrelic
- # Enable the service
- systemctl enable newrelic-daemon.service
-
# When first installing the package, the license key will not be set.
# Instead of throwing an error, we want to whine to the user and then exit cleanly.
if sed -e '/^[ ]*#/d' "${inifile}" 2> /dev/null | grep -q 'REPLACE_WITH_REAL_KEY' 2> /dev/null; then
if [ -z "${NR_SILENT}" -a -z "${SILENT}" ]; then
echo \
"
-:: The service cannot be started until a valid licence is inserted in the following file:
+:: The service cannot be started until a valid licence is detected in:
/etc/php/conf.d/newrelic.ini
-:: Edit the above referenced file and in newrelic.license=\"REPLACE_WITH_REAL_KEY\"
- replace the value with your licence key. More information here:
-
- https://docs.newrelic.com/docs/apm/agents/php-agent/getting-started/introduction-new-relic-php/#installation
+:: Edit the above file and replace \"newrelic.license\" parameter with your licence key.
+ More information here:
-:: No data will be reported until the daemon can be started.
- Get your license key in \"Settings\" of the \"Support\" menu in your NewRelic account.
- (accessible at https://rpm.newrelic.com)
+ https://docs.newrelic.com/docs/apm/agents/php-agent/installation/php-agent-installation-overview/#install-overview
-:: Once the license key is configured, start the NewRelic daemon, PHP and the web server.
+:: Get your license key under \"Settings\" in the \"Support\" menu of your NewRelic account.
+ (accessible at https://one.newrelic.com/api-keys)
"
fi
return 0
@@ -37,5 +31,4 @@ post_install() {
post_remove() {
userdel newrelic || true
- rm -rf /var/log/newrelic
} \ No newline at end of file