summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCody Bond2020-06-17 18:34:03 -0400
committerCody Bond2020-06-17 18:34:03 -0400
commitd9bb7b12b3d469c2ac550c41a505dc14a1a78ce7 (patch)
treea0dec0cbf464ded411980d2e9c031f31b1683144
downloadaur-d9bb7b12b3d469c2ac550c41a505dc14a1a78ce7.tar.gz
Added PKGBUILD and .SRCINFO.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a101a0adda6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = newsie
+ pkgdesc = A command line utility for accessing Arch newsfeed posts.
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/cbbond/newsie
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-docopt
+ depends = python-feedparser
+ source = https://github.com/cbbond/newsie/archive/0.2.tar.gz
+ md5sums = 631c2d2a62488885aafb2ba941cb041a
+
+pkgname = newsie
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46b6e669d0fe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Cody Bond <cbbond@outlook.com>
+
+pkgname=newsie
+pkgver=0.2
+pkgrel=1
+pkgdesc="A command line utility for accessing Arch newsfeed posts."
+arch=("any")
+url="https://github.com/cbbond/$pkgname"
+license=('MIT')
+depends=("python" "python-docopt" "python-feedparser")
+source=("https://github.com/cbbond/$pkgname/archive/$pkgver.tar.gz")
+md5sums=('631c2d2a62488885aafb2ba941cb041a')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm 0755 $pkgname -t $pkgdir/usr/bin/
+ install -Dm 0644 $pkgname.hook -T $pkgdir/usr/share/libalpm/hooks/00-$pkgname.hook
+ install -Dm 0644 LICENSE -t $pkgdir/usr/share/licenses/$pkgname/
+}