summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-08-17 18:21:37 +0200
committerhaawda2019-08-17 18:21:37 +0200
commit48c7718c72580fa1a82a1bba1dbfd1c9ffb91b8e (patch)
tree0bee01575be2dd78e428e7dc07cda213f1fef92c
downloadaur-48c7718c72580fa1a82a1bba1dbfd1c9ffb91b8e.tar.gz
initial upload
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD33
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6025a79661f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = next-browser
+ pkgdesc = Keyboard-oriented, Common Lisp extensible web-browser
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://next.atlas.engineer
+ arch = i686
+ arch = x86_64
+ license = custom:BSD
+ makedepends = git
+ makedepends = sbcl
+ makedepends = cl-asdf
+ depends = webkit2gtk
+ depends = sqlite
+ depends = glib-networking
+ depends = gsettings-desktop-schemas
+ depends = libfixposix
+ optdepends = gstreamer: for HTML5 audio/video
+ optdepends = gst-plugins-base: for HTML5 audio/video
+ optdepends = gst-plugins-good: for HTML5 audio/video
+ optdepends = gst-plugins-bad: for HTML5 audio/video
+ optdepends = gst-plugins-ugly: for HTML5 audio/video
+ options = !strip
+ options = !makeflags
+ source = next-browser-1.3.0::https://github.com/atlas-engineer/next/archive/1.3.0.tar.gz
+ sha256sums = e459c1f2432bfda853895417be94c6ea0a4254eb060a9a3f5a56491a17fd6da7
+
+pkgname = next-browser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30e66e8b8b08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Contributor: Cillian Berragan <cjberragan@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=next-browser
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Keyboard-oriented, Common Lisp extensible web-browser"
+arch=('i686' 'x86_64')
+url="https://next.atlas.engineer"
+license=('custom:BSD')
+source=("$pkgname-$pkgver::https://github.com/atlas-engineer/next/archive/$pkgver.tar.gz")
+sha256sums=('e459c1f2432bfda853895417be94c6ea0a4254eb060a9a3f5a56491a17fd6da7')
+# If someday Next works with other Lisps, replace 'sbcl' with 'common-lisp'.
+makedepends=('git' 'sbcl' 'cl-asdf')
+depends=('webkit2gtk' 'sqlite' 'glib-networking' 'gsettings-desktop-schemas' 'libfixposix')
+optdepends=('gstreamer: for HTML5 audio/video'
+ 'gst-plugins-base: for HTML5 audio/video'
+ 'gst-plugins-good: for HTML5 audio/video'
+ 'gst-plugins-bad: for HTML5 audio/video'
+ 'gst-plugins-ugly: for HTML5 audio/video')
+# Binary will not run otherwise.
+options=('!strip' '!makeflags')
+
+build() {
+ cd ${pkgname%-browser}-$pkgver
+ make all
+}
+
+package() {
+ cd ${pkgname%-browser}-$pkgver
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}