summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormsrd0.dev2024-04-08 12:57:47 +0000
committermsrd0.dev2024-04-08 12:57:47 +0000
commit63b1669bd2bf89b8b5ca952bb53e1d766f919d21 (patch)
tree7097724e78637c4af3e227e4c1a07234549f68c3
parent188487d9ee8dbc4bd3ea949a0cfbfae19050bd04 (diff)
downloadaur-next-rust-release-date.tar.gz
auto-update next-rust-release-date 0.2.0
-rw-r--r--.SRCINFO2
-rw-r--r--.index.json2
-rw-r--r--PKGBUILD24
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 209fedc3db76..45717e427ee2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,7 @@ pkgbase = next-rust-release-date
arch = aarch64
arch = i686
arch = x86_64
- license = Apache
+ license = Apache-2.0
license = MIT
makedepends = cargo
depends = gcc-libs
diff --git a/.index.json b/.index.json
index a5e8056bec86..c446ff7c51d5 100644
--- a/.index.json
+++ b/.index.json
@@ -1,5 +1,5 @@
{
- ".i": 1,
+ ".i": 2,
"crate": "next-rust-release-date",
"version": "0.2.0"
} \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d2164afd3e82..dbdadcf3e0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,25 +7,33 @@ pkgver=0.2.0
pkgrel=1
pkgdesc='When'"'"'s the next Rust release?'
url='https://crates.io/crates/next-rust-release-date'
-license=('Apache' 'MIT')
+license=('Apache-2.0' 'MIT')
depends=('gcc-libs')
makedepends=('cargo')
-source=("$_crate-$pkgver.tar.gz::https://crates.io/api/v1/crates/next-rust-release-date/0.2.0/download")
+source=("$_crate-0.2.0.tar.gz::https://crates.io/api/v1/crates/next-rust-release-date/0.2.0/download")
sha512sums=('1989219159382aa07b6ce43967ed70b10a045487c02bab78b4d65122b82887a1940fabfa2d285aa7350f416259e9faa080d2952b2a18d3b3db84e50bde7bdf49')
# Tier 1 architectures supported by Rust (https://doc.rust-lang.org/nightly/rustc/platform-support.html#tier-1)
arch=('aarch64' 'i686' 'x86_64')
prepare() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.2.0"
- cargo fetch --locked
+ export RUSTUP_TOOLCHAIN=stable
+
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
}
build() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.2.0"
+
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ CFLAGS+=" -ffat-lto-objects"
+
+
cargo build \
--offline \
--locked \
@@ -33,8 +41,8 @@ build() {
}
package() {
- cd "$srcdir/$_crate-$pkgver"
+ cd "$srcdir/$_crate-0.2.0"
install -Dm755 "target/release/next-rust-release-date" -t "$pkgdir/usr/bin"
- install -Dm644 "LICENSE-APACHE" -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 "LICENSE-MIT" -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 'LICENSE-MIT' -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 'LICENSE-APACHE' -t "$pkgdir/usr/share/licenses/$pkgname/"
} \ No newline at end of file