summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2020-05-17 00:56:39 +0200
committerMuflone2020-05-17 00:56:39 +0200
commitcc0a5f60659182cc6d7a7e50d30020d2dbb4b7cb (patch)
tree8c4257a68c986283ab5b55f7c309a5cacba23977
parent0a027e8d29f2c19598d73a1915add7bec75a9bca (diff)
downloadaur-cc0a5f60659182cc6d7a7e50d30020d2dbb4b7cb.tar.gz
Updated package nexcloud-10 10.0.6-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD47
-rw-r--r--apache.example.conf29
-rwxr-xr-xnextcloud-set-permissions.sh (renamed from set-nc-perms.sh)0
4 files changed, 54 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e08381cd04f4..c2c2fcb5598f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
-# Generated by mksrcinfo v8
-# Sat Mar 4 21:06:12 UTC 2017
pkgbase = nextcloud-10
pkgdesc = A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way (Version 10.x for migrating from ownCloud 9.x)
- pkgver = 10.0.4
+ pkgver = 10.0.6
pkgrel = 1
url = https://nextcloud.com
arch = any
license = AGPL
- depends = php
- depends = php-gd
+ makedepends = systemd
+ depends = php<7.4
+ depends = php-gd<7.4
optdepends = php-apache: to use the Apache web server
optdepends = php-sqlite: to use the SQLite database backend
optdepends = php-pgsql: to use the PostgreSQL database backend
@@ -24,13 +23,14 @@ pkgbase = nextcloud-10
conflicts = nextcloud
options = !strip
options = emptydirs
- source = https://download.nextcloud.com/server/releases/nextcloud-10.0.4.tar.bz2
- source = https://download.nextcloud.com/server/releases/nextcloud-10.0.4.tar.bz2.asc
+ source = https://download.nextcloud.com/server/releases/nextcloud-10.0.6.tar.bz2
+ source = https://download.nextcloud.com/server/releases/nextcloud-10.0.6.tar.bz2.asc
source = apache.example.conf
- source = set-nc-perms.sh
- sha256sums = d80aa7c14ab2ec486d465833ec6e404e13fe19f6b10c41b4d48b277c95dc262a
+ source = nextcloud-set-permissions.sh
+ validpgpkeys = 28806A878AE423A28372792ED75899B9A724937A
+ sha256sums = 1b9acad0fa3317047902fd647c425a1d567e7d93ffa9c40700d072a45cf396f1
sha256sums = SKIP
- sha256sums = f9ff4ecee6bca01a2820e0f8509e4ef59343fb91fa2ada205ced2d3765c7d707
+ sha256sums = e3d802ae8c868bafd3efc884f0fd8eaa36dac0769718a54a14303fbf386fd87a
sha256sums = 6622fc3beba36d055b10b6a661bfe9ca44373277edfa4ce9d5ac8258893efd02
pkgname = nextcloud-10
diff --git a/PKGBUILD b/PKGBUILD
index 397b3dbb026a..e235823a5305 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,51 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
# Contributor: Grey Christoforo <first name [at] last name [dot] net>
+# Contributor: Felix Golatofski <contact@xdfr.de>
pkgname=nextcloud-10
-pkgver=10.0.4
+pkgver=10.0.6
pkgrel=1
pkgdesc="A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way (Version 10.x for migrating from ownCloud 9.x)"
url="https://nextcloud.com"
arch=('any')
license=('AGPL')
-depends=('php' 'php-gd')
+makedepends=('systemd')
+depends=('php<7.4' 'php-gd<7.4')
optdepends=('php-apache: to use the Apache web server'
- 'php-sqlite: to use the SQLite database backend'
- 'php-pgsql: to use the PostgreSQL database backend'
- 'php-ldap: LDAP authentication'
- 'php-intl'
- 'php-apcu: Memory caching'
- 'mariadb: to use the MySQL database backend'
- 'smbclient: to mount SAMBA shares'
- 'php-mcrypt'
- 'imagemagick: file preview'
- 'ffmpeg: file preview'
- 'libreoffice: file preview')
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu: Memory caching'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'imagemagick: file preview'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
conflicts=('nextcloud')
validpgpkeys=('28806A878AE423A28372792ED75899B9A724937A')
source=("https://download.nextcloud.com/server/releases/nextcloud-${pkgver}.tar.bz2"{,.asc}
"apache.example.conf"
- "set-nc-perms.sh")
-sha256sums=('d80aa7c14ab2ec486d465833ec6e404e13fe19f6b10c41b4d48b277c95dc262a'
+ "nextcloud-set-permissions.sh")
+sha256sums=('1b9acad0fa3317047902fd647c425a1d567e7d93ffa9c40700d072a45cf396f1'
'SKIP'
- 'f9ff4ecee6bca01a2820e0f8509e4ef59343fb91fa2ada205ced2d3765c7d707'
+ 'e3d802ae8c868bafd3efc884f0fd8eaa36dac0769718a54a14303fbf386fd87a'
'6622fc3beba36d055b10b6a661bfe9ca44373277edfa4ce9d5ac8258893efd02')
options=(!strip emptydirs)
package() {
- install -d "${pkgdir}/usr/share/licenses/${pkgname}"
-
- mkdir -p "${pkgdir}/usr/share/webapps"
+ # install project
+ install -d -m 755 "${pkgdir}/usr/share/webapps"
cp -a nextcloud "${pkgdir}/usr/share/webapps/."
# set the proper permissions
- "${srcdir}/set-nc-perms.sh" runtime "${pkgdir}/usr/share/webapps/nextcloud"
+ install -D -m 755 "${srcdir}/nextcloud-set-permissions.sh" "${pkgdir}/usr/bin/nextcloud-set-permissions"
+ "${srcdir}/nextcloud-set-permissions.sh" runtime "${pkgdir}/usr/share/webapps/nextcloud"
- install -D -m 755 "${srcdir}/set-nc-perms.sh" "${pkgdir}/usr/bin/set-nc-perms"
+ # install apache example config file
install -D -m 644 "${srcdir}/apache.example.conf" -t "${pkgdir}/etc/webapps/nextcloud"
+
+ # install executable launcher
ln -s /usr/share/webapps/nextcloud/occ "${pkgdir}/usr/bin/occ"
}
-
diff --git a/apache.example.conf b/apache.example.conf
index 84f452ac274c..8033c907c018 100644
--- a/apache.example.conf
+++ b/apache.example.conf
@@ -1,15 +1,24 @@
-Alias /nextcloud "/usr/share/webapps/nextcloud"
+<IfModule mod_alias.c>
+ Alias /nextcloud "/usr/share/webapps/nextcloud"
+</IfModule>
<Directory /usr/share/webapps/nextcloud/>
- Options +FollowSymlinks
- AllowOverride All
- Require all granted
+ Options +FollowSymlinks
+ AllowOverride All
+ Require all granted
- <IfModule mod_dav.c>
- Dav off
- </IfModule>
-
- SetEnv HOME /usr/share/webapps/nextcloud
- SetEnv HTTP_HOME /usr/share/webapps/nextcloud
+ <IfModule mod_dav.c>
+ Dav off
+ </IfModule>
+ SetEnv HOME /usr/share/webapps/nextcloud
+ SetEnv HTTP_HOME /usr/share/webapps/nextcloud
</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/nextcloud
+ ServerName nextcloud.example.com
+ ErrorLog /var/log/httpd/nextcloud.example.com-error_log
+ CustomLog /var/log/httpd/nextcloud.example.com-access_log common
+</VirtualHost>
diff --git a/set-nc-perms.sh b/nextcloud-set-permissions.sh
index 849b565ad5ad..849b565ad5ad 100755
--- a/set-nc-perms.sh
+++ b/nextcloud-set-permissions.sh