summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2016-12-27 16:37:39 +0100
committerJonas Heinrich2016-12-27 16:37:39 +0100
commit162febde3fd73fef33d107298164918966b470d5 (patch)
tree90eddfe7ef55cf43ca4d2cfce50ce3589b9a78a7
downloadaur-162febde3fd73fef33d107298164918966b470d5.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6e6a0a6768f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Dec 27 15:37:24 UTC 2016
+pkgbase = nextcloud-app-contacts-git
+ pkgdesc = Contacts app for Nextcloud
+ pkgver = 1.4.0.0.r92.g5869e14
+ pkgrel = 1
+ url = https://github.com/nextcloud/contacts
+ arch = any
+ license = AGPL
+ depends = nextcloud
+ provides = nextcloud-app-contacts
+ conflicts = nextcloud-app-contacts
+ options = !strip
+ source = git+https://github.com/nextcloud/contacts.git
+ sha512sums = SKIP
+
+pkgname = nextcloud-app-contacts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b0148f3e0c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=nextcloud-app-contacts-git
+pkgver=1.4.0.0.r92.g5869e14
+pkgrel=1
+pkgdesc="Contacts app for Nextcloud"
+arch=('any')
+url="https://github.com/nextcloud/contacts"
+license=('AGPL')
+depends=('nextcloud')
+options=('!strip')
+provides=('nextcloud-app-contacts')
+conflicts=('nextcloud-app-contacts')
+source=("git+https://github.com/nextcloud/contacts.git")
+sha512sums=("SKIP")
+
+pkgver() {
+ cd "contacts"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
+}
+
+build() {
+ cd "${srcdir}/contacts"
+ make
+ make appstore
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ tar -xvf "${srcdir}/contacts/build/artifacts/appstore/contacts.tar.gz" -C "${pkgdir}/usr/share/webapps/nextcloud/apps/"
+ install -D "${srcdir}/contacts/COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}