summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilrain2021-03-24 09:57:20 +0100
committerGilrain2021-03-24 09:57:20 +0100
commit27096f9482ba2ec32e3a7eb43c5471e462c8aed9 (patch)
treeb44aede2482a4b70f6056fa9208dbb4450128ec8
downloadaur-27096f9482ba2ec32e3a7eb43c5471e462c8aed9.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b705dbdbf11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nextcloud-app-files-antivirus
+ pkgdesc = Antivirus app for Nextcloud
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = https://github.com/nextcloud/files_antivirus
+ arch = any
+ license = AGPL3
+ depends = nextcloud
+ depends = clamav
+ options = !strip
+ source = nextcloud-app-files-antivirus-3.2.0.tar.gz::https://github.com/nextcloud/files_antivirus/releases/download/v3.2.0/files_antivirus.tar.gz
+ sha512sums = a8c5326928956fec6daa18689b588612970237686169c56ba159df53e63910ae146c00550ed7eab88d805aa71b786fcc34f1417833eba097e2258409c61cea1e
+
+pkgname = nextcloud-app-files-antivirus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b86d18aacb38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Gilrain <gilrain+libre.arch A_T castelmo DOT_ re>
+# Contributor: Sergej Pupykin <arch+pub@sergej.pp.ru>
+# Contributor: David Runge <dave@sleepmap.de>
+
+pkgname=nextcloud-app-files-antivirus
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Antivirus app for Nextcloud"
+arch=('any')
+url="https://github.com/nextcloud/files_antivirus"
+license=('AGPL3')
+depends=('nextcloud' 'clamav')
+makedepends=()
+options=('!strip')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nextcloud/files_antivirus/releases/download/v${pkgver}/files_antivirus.tar.gz")
+sha512sums=('a8c5326928956fec6daa18689b588612970237686169c56ba159df53e63910ae146c00550ed7eab88d805aa71b786fcc34f1417833eba097e2258409c61cea1e')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -R "${srcdir}/files_antivirus" "${pkgdir}/usr/share/webapps/nextcloud/apps/files_antivirus"
+}