summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-10 18:15:16 +0100
committerJiří Kuchyňka (Anty)2021-02-10 18:15:16 +0100
commit5f9f6ea74d8f83152af365bc31b3ad73fcae1a6f (patch)
tree30630bd2f6d0d6a495437076279440ff506cbdb7
downloadaur-5f9f6ea74d8f83152af365bc31b3ad73fcae1a6f.tar.gz
initial commit;
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD20
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b04bf8150e78
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nextcloud-app-integration-gitlab
+ pkgdesc = GitLab integration into Nextcloud
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://github.com/nextcloud/integration_gitlab
+ arch = any
+ license = AGPL3
+ depends = nextcloud
+ options = !strip
+ source = integration_gitlab-v0.0.13.tar.gz::https://github.com/nextcloud/integration_gitlab/releases/download/v0.0.13/integration_gitlab-0.0.13.tar.gz
+ sha512sums = b9fec91925d1cd5ff50aa3eadc035d068dc4568d500cec68b22eb68e269899b9b6f5364ebcab497f41dd661976be1ef9713d3b2d24509a9a4e76562c04612333
+
+pkgname = nextcloud-app-integration-gitlab
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e1c38b577ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb90bc475e80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Anty0 <anty150 at gmail dot com>
+
+pkgdesc='GitLab integration into Nextcloud'
+pkgname=('nextcloud-app-integration-gitlab')
+_appname='integration_gitlab'
+pkgver=0.0.13
+pkgrel=1
+arch=('any')
+license=('AGPL3')
+url="https://github.com/nextcloud/integration_gitlab"
+makedepends=()
+depends=('nextcloud')
+options=('!strip')
+source=("${_appname}-v${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.tar.gz")
+sha512sums=('b9fec91925d1cd5ff50aa3eadc035d068dc4568d500cec68b22eb68e269899b9b6f5364ebcab497f41dd661976be1ef9713d3b2d24509a9a4e76562c04612333')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/${_appname}" "${pkgdir}/usr/share/webapps/nextcloud/apps/${_appname}"
+}