summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-23 11:27:19 +0100
committerJiří Kuchyňka (Anty)2021-02-23 11:27:19 +0100
commit9edf6bd13719eccb3aaa701dfba4a644032cc905 (patch)
tree5832e0788f0d5ed5bbac0bcc2114997396e5d929
parent5f9f6ea74d8f83152af365bc31b3ad73fcae1a6f (diff)
downloadaur-9edf6bd13719eccb3aaa701dfba4a644032cc905.tar.gz
update to 0.0.15;
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rwxr-xr-xupdate.sh36
3 files changed, 43 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b04bf8150e78..de3878649a47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nextcloud-app-integration-gitlab
pkgdesc = GitLab integration into Nextcloud
- pkgver = 0.0.13
+ pkgver = 0.0.15
pkgrel = 1
url = https://github.com/nextcloud/integration_gitlab
arch = any
license = AGPL3
depends = nextcloud
options = !strip
- source = integration_gitlab-v0.0.13.tar.gz::https://github.com/nextcloud/integration_gitlab/releases/download/v0.0.13/integration_gitlab-0.0.13.tar.gz
- sha512sums = b9fec91925d1cd5ff50aa3eadc035d068dc4568d500cec68b22eb68e269899b9b6f5364ebcab497f41dd661976be1ef9713d3b2d24509a9a4e76562c04612333
+ source = integration_gitlab-v0.0.15.tar.gz::https://github.com/nextcloud/integration_gitlab/releases/download/v0.0.15/integration_gitlab-0.0.15.tar.gz
+ sha512sums = 881e54cbaff3b579d02ed4eac11179a6d25b924d004afed7973d9cc9efc34199350d613658f243f330f0cdab3e957522bb285e701f2d34b8d11f524d78db8288
pkgname = nextcloud-app-integration-gitlab
diff --git a/PKGBUILD b/PKGBUILD
index fb90bc475e80..eecf2e20f684 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
pkgdesc='GitLab integration into Nextcloud'
pkgname=('nextcloud-app-integration-gitlab')
_appname='integration_gitlab'
-pkgver=0.0.13
+pkgver='0.0.15'
pkgrel=1
arch=('any')
license=('AGPL3')
-url="https://github.com/nextcloud/integration_gitlab"
+_repo="nextcloud/integration_gitlab"
+url="https://github.com/${_repo}"
makedepends=()
depends=('nextcloud')
options=('!strip')
source=("${_appname}-v${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.tar.gz")
-sha512sums=('b9fec91925d1cd5ff50aa3eadc035d068dc4568d500cec68b22eb68e269899b9b6f5364ebcab497f41dd661976be1ef9713d3b2d24509a9a4e76562c04612333')
+sha512sums=('881e54cbaff3b579d02ed4eac11179a6d25b924d004afed7973d9cc9efc34199350d613658f243f330f0cdab3e957522bb285e701f2d34b8d11f524d78db8288')
package() {
install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..71479f11658a
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+set -e
+
+SCRIPT_DIR="$(dirname "$0")"
+cd "$SCRIPT_DIR"
+
+source ./PKGBUILD
+
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name' | cut -c 2-)"
+VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name' | cut -c 2-)"
+
+if [ "${pkgver}" = "${VERSION}" ]; then
+ echo "${pkgname}: No updates"
+ exit
+fi
+
+echo "${pkgname}: ${pkgver} -> ${VERSION}"
+
+if [ "$1" = "--check" ]; then
+ exit
+fi
+
+# Update
+sed -i -e "s/^pkgver=.*\$/pkgver='${VERSION}'/" -e "s/^pkgrel=.*\$/pkgrel=1/" PKGBUILD
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO
+
+# Build and install
+makepkg -sicr
+
+# Commit
+git add .
+git commit -m "update to ${VERSION};"