summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-23 11:27:45 +0100
committerJiří Kuchyňka (Anty)2021-02-23 11:27:45 +0100
commitb713543c49359b84081ff5f4929532efa019c033 (patch)
tree89b1675f499d45a48e9842fb6acbbee7302b08cb
parente9b012e6421fe6e6e48b7c409b6b9d6f269a397d (diff)
downloadaur-b713543c49359b84081ff5f4929532efa019c033.tar.gz
update to 0.1.10;
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rwxr-xr-xupdate.sh36
3 files changed, 43 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a97b9ee91b19..ebeba7b27280 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nextcloud-app-integration-google
pkgdesc = Google integration in Nextcloud
- pkgver = 0.1.7
+ pkgver = 0.1.10
pkgrel = 1
url = https://github.com/nextcloud/integration_google
arch = any
license = AGPL3
depends = nextcloud
options = !strip
- source = integration_google-v0.1.7.tar.gz::https://github.com/nextcloud/integration_google/releases/download/v0.1.7/integration_google-0.1.7.tar.gz
- sha512sums = 8a1c60399ba9c59b7f80da0f501ae7b4206d0f824fc963cc702cf10e3ae881cfe481df2e89738d4e021f42c280f8108a0820e115c447d98b8172b7704d0e74be
+ source = integration_google-v0.1.10.tar.gz::https://github.com/nextcloud/integration_google/releases/download/v0.1.10/integration_google-0.1.10.tar.gz
+ sha512sums = f697fec89c3a1b4d30001307c23b22127b3301542c32d9c874e6256af5b518085685d69cd996da99c3d42d11d44197f18b1c1df240bf6d57c11e668da406255f
pkgname = nextcloud-app-integration-google
diff --git a/PKGBUILD b/PKGBUILD
index bae2ea3d370c..9983c33f5e56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
pkgdesc='Google integration in Nextcloud'
pkgname=('nextcloud-app-integration-google')
_appname='integration_google'
-pkgver=0.1.7
+pkgver='0.1.10'
pkgrel=1
arch=('any')
license=('AGPL3')
-url="https://github.com/nextcloud/integration_google"
+_repo="nextcloud/integration_google"
+url="https://github.com/${_repo}"
makedepends=()
depends=('nextcloud')
options=('!strip')
source=("${_appname}-v${pkgver}.tar.gz::${url}/releases/download/v${pkgver}/${_appname}-${pkgver}.tar.gz")
-sha512sums=('8a1c60399ba9c59b7f80da0f501ae7b4206d0f824fc963cc702cf10e3ae881cfe481df2e89738d4e021f42c280f8108a0820e115c447d98b8172b7704d0e74be')
+sha512sums=('f697fec89c3a1b4d30001307c23b22127b3301542c32d9c874e6256af5b518085685d69cd996da99c3d42d11d44197f18b1c1df240bf6d57c11e668da406255f')
package() {
install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..71479f11658a
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,36 @@
+#!/bin/sh
+
+set -e
+
+SCRIPT_DIR="$(dirname "$0")"
+cd "$SCRIPT_DIR"
+
+source ./PKGBUILD
+
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name' | cut -c 2-)"
+VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name' | cut -c 2-)"
+
+if [ "${pkgver}" = "${VERSION}" ]; then
+ echo "${pkgname}: No updates"
+ exit
+fi
+
+echo "${pkgname}: ${pkgver} -> ${VERSION}"
+
+if [ "$1" = "--check" ]; then
+ exit
+fi
+
+# Update
+sed -i -e "s/^pkgver=.*\$/pkgver='${VERSION}'/" -e "s/^pkgrel=.*\$/pkgrel=1/" PKGBUILD
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO
+
+# Build and install
+makepkg -sicr
+
+# Commit
+git add .
+git commit -m "update to ${VERSION};"