summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-10 20:51:40 +0100
committerJiří Kuchyňka (Anty)2021-02-10 20:51:40 +0100
commitb9d177a5bb8b7faf87cb8c05644fbace8304a35e (patch)
treee184ede7be72cfe2bf0f17766113fd5f09912117
downloadaur-b9d177a5bb8b7faf87cb8c05644fbace8304a35e.tar.gz
initial commit;
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58eb80e45811
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nextcloud-app-ocdownloader
+ pkgdesc = Easy to use download manager using Curl/Aria2 and youtube-dl for Nextcloud
+ pkgver = 1.7.10
+ pkgrel = 1
+ url = https://github.com/e-alfred/ocdownloader
+ arch = any
+ license = AGPL3
+ depends = nextcloud
+ optdepends = aria2: To use aria2 as download manager
+ optdepends = curl: To download files using curl
+ optdepends = youtube-dl: To download videos
+ options = !strip
+ source = ocdownloader-v1.7.10.tar.gz::https://github.com/e-alfred/ocdownloader/releases/download/1.7.10/ocdownloader-1.7.10.tar.gz
+ sha512sums = ab63b98219487e6ae565dc1f590f9a1b85019211df024186223d9150914655ff41d8fbdd116ff45340d0a589d0fae289d8d0474867726e586cda42e664ed3fee
+
+pkgname = nextcloud-app-ocdownloader
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e1c38b577ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8998aec2ce8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Anty0 <anty150 at gmail dot com>
+
+pkgdesc='Easy to use download manager using Curl/Aria2 and youtube-dl for Nextcloud'
+pkgname=('nextcloud-app-ocdownloader')
+_appname='ocdownloader'
+pkgver=1.7.10
+pkgrel=1
+arch=('any')
+license=('AGPL3')
+url="https://github.com/e-alfred/ocdownloader"
+makedepends=()
+depends=('nextcloud')
+optdepends=(
+ 'aria2: To use aria2 as download manager'
+ 'curl: To download files using curl'
+ 'youtube-dl: To download videos')
+options=('!strip')
+source=("${_appname}-v${pkgver}.tar.gz::${url}/releases/download/${pkgver}/${_appname}-${pkgver}.tar.gz")
+sha512sums=('ab63b98219487e6ae565dc1f590f9a1b85019211df024186223d9150914655ff41d8fbdd116ff45340d0a589d0fae289d8d0474867726e586cda42e664ed3fee')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/${_appname}" "${pkgdir}/usr/share/webapps/nextcloud/apps/${_appname}"
+}