summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-23 11:28:13 +0100
committerJiří Kuchyňka (Anty)2021-02-23 11:28:13 +0100
commit0b25750947e515d6fe044fccab53cc6ee3f220ac (patch)
tree6675e46eda4b74d1542dde24b6783f1b4e36c935
parentec4414359c6b65927f1f48f207fdcc464f86680e (diff)
downloadaur-0b25750947e515d6fe044fccab53cc6ee3f220ac.tar.gz
update to 2021.2.0;
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rwxr-xr-xupdate.sh39
3 files changed, 45 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5662b3556f03..de89207aee84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nextcloud-app-passwords
pkgdesc = Easy to use yet feature-rich and secure password manager for Nextcloud
- pkgver = 2021.1.3
+ pkgver = 2021.2.0
pkgrel = 1
url = https://apps.nextcloud.com/apps/passwords
arch = any
license = AGPL3
depends = nextcloud
options = !strip
- source = passwords-v2021.1.3.tar.gz::https://git.mdns.eu/nextcloud/passwords/-/jobs/11555/artifacts/raw/passwords.tar.gz
- sha512sums = e04f2a9a6d68a0183c3d4f6984a767b4aa4e7865ba6bea7f9c898a21d5909e876a6230e524008d87d357d28771c67a33959793f2418d0ac12351d54328a8b788
+ source = passwords-v2021.2.0.tar.gz::https://git.mdns.eu/nextcloud/passwords/-/jobs/11640/artifacts/raw/passwords.tar.gz
+ sha512sums = ebd782b7bb35d97b4c132ee8097d321cad8789bf31f6de30e732fb60be23e91e77b286c49a0f38993b7435a3d2d3ab38fc3654027888466e2a472fc511863173
pkgname = nextcloud-app-passwords
diff --git a/PKGBUILD b/PKGBUILD
index f6c0720ccc59..ea89b5e4f4b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgdesc='Easy to use yet feature-rich and secure password manager for Nextcloud'
pkgname=('nextcloud-app-passwords')
_appname='passwords'
-_jobid='11555'
-pkgver=2021.1.3
+_jobid='11640'
+pkgver='2021.2.0'
pkgrel=1
arch=('any')
license=('AGPL3')
@@ -13,7 +13,7 @@ makedepends=()
depends=('nextcloud')
options=('!strip')
source=("${_appname}-v${pkgver}.tar.gz::https://git.mdns.eu/nextcloud/passwords/-/jobs/${_jobid}/artifacts/raw/${_appname}.tar.gz")
-sha512sums=('e04f2a9a6d68a0183c3d4f6984a767b4aa4e7865ba6bea7f9c898a21d5909e876a6230e524008d87d357d28771c67a33959793f2418d0ac12351d54328a8b788')
+sha512sums=('ebd782b7bb35d97b4c132ee8097d321cad8789bf31f6de30e732fb60be23e91e77b286c49a0f38993b7435a3d2d3ab38fc3654027888466e2a472fc511863173')
package() {
install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..fdc9c427927e
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,39 @@
+#!/bin/sh
+
+set -e
+
+SCRIPT_DIR="$(dirname "$0")"
+cd "$SCRIPT_DIR"
+
+source ./PKGBUILD
+
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name')"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/tags" 2>/dev/null | jq -r '.[0].name' | cut -c 2-)"
+#VERSION="$(curl -H "Accept: application/vnd.github.v3+json" "https://api.github.com/repos/${_repo}/releases/latest" 2>/dev/null | jq -r '.tag_name' | cut -c 2-)"
+_APP_INFO="$(curl "https://apps.nextcloud.com/api/v1/platform/21.0.0/apps.json" 2>/dev/null)"
+VERSION="$(echo "${_APP_INFO}" | jq -r '[.[] | select(.id == "passwords") | .releases[] | select(.isNightly == false)] | .[0].version')"
+JOBID="$(echo "${_APP_INFO}" | jq -r '[.[] | select(.id == "passwords") | .releases[] | select(.isNightly == false)] | .[0].download' | cut -d/ -f 8)"
+
+if [ "${pkgver}" = "${VERSION}" ]; then
+ echo "${pkgname}: No updates"
+ exit
+fi
+
+echo "${pkgname}: ${pkgver} -> ${VERSION} (${JOBID})"
+
+if [ "$1" = "--check" ]; then
+ exit
+fi
+
+# Update
+sed -i -e "s/^pkgver=.*\$/pkgver='${VERSION}'/" -e "s/^pkgrel=.*\$/pkgrel=1/" -e "s/^_jobid=.*\$/_jobid='${JOBID}'/" PKGBUILD
+updpkgsums
+makepkg --printsrcinfo > .SRCINFO
+
+# Build and install
+makepkg -sicr
+
+# Commit
+git add .
+git commit -m "update to ${VERSION};"