summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Kuchyňka (Anty)2021-02-10 19:54:45 +0100
committerJiří Kuchyňka (Anty)2021-02-10 19:54:45 +0100
commitec4414359c6b65927f1f48f207fdcc464f86680e (patch)
treeaf60e7d54b1e932a08188b4f80d1ee7224b4d692
downloadaur-ec4414359c6b65927f1f48f207fdcc464f86680e.tar.gz
initial commit;
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD21
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5662b3556f03
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nextcloud-app-passwords
+ pkgdesc = Easy to use yet feature-rich and secure password manager for Nextcloud
+ pkgver = 2021.1.3
+ pkgrel = 1
+ url = https://apps.nextcloud.com/apps/passwords
+ arch = any
+ license = AGPL3
+ depends = nextcloud
+ options = !strip
+ source = passwords-v2021.1.3.tar.gz::https://git.mdns.eu/nextcloud/passwords/-/jobs/11555/artifacts/raw/passwords.tar.gz
+ sha512sums = e04f2a9a6d68a0183c3d4f6984a767b4aa4e7865ba6bea7f9c898a21d5909e876a6230e524008d87d357d28771c67a33959793f2418d0ac12351d54328a8b788
+
+pkgname = nextcloud-app-passwords
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e1c38b577ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6c0720ccc59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Anty0 <anty150 at gmail dot com>
+
+pkgdesc='Easy to use yet feature-rich and secure password manager for Nextcloud'
+pkgname=('nextcloud-app-passwords')
+_appname='passwords'
+_jobid='11555'
+pkgver=2021.1.3
+pkgrel=1
+arch=('any')
+license=('AGPL3')
+url="https://apps.nextcloud.com/apps/passwords"
+makedepends=()
+depends=('nextcloud')
+options=('!strip')
+source=("${_appname}-v${pkgver}.tar.gz::https://git.mdns.eu/nextcloud/passwords/-/jobs/${_jobid}/artifacts/raw/${_appname}.tar.gz")
+sha512sums=('e04f2a9a6d68a0183c3d4f6984a767b4aa4e7865ba6bea7f9c898a21d5909e876a6230e524008d87d357d28771c67a33959793f2418d0ac12351d54328a8b788')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/${_appname}" "${pkgdir}/usr/share/webapps/nextcloud/apps/${_appname}"
+}