summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Klomp2018-02-17 21:13:02 +0100
committerSven Klomp2018-02-17 21:13:02 +0100
commitaa7de093603c63ab7213009a04ec7e8c2d88137b (patch)
tree4e1102506db264294c8a8f8f7c7fa511666a51a5
downloadaur-aa7de093603c63ab7213009a04ec7e8c2d88137b.tar.gz
Add initial files
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c6669087e5e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Feb 17 20:11:22 UTC 2018
+pkgbase = nextcloud-app-picocms
+ pkgdesc = Allows to create a website as a subfolder of the cloud.
+ pkgver = 0.9.7
+ pkgrel = 1
+ url = https://github.com/nextcloud/cms_pico
+ arch = any
+ license = AGPL
+ depends = nextcloud
+ options = !strip
+ source = cms_pico-0.9.7.tar.gz::https://github.com/nextcloud/cms_pico/releases/download/v0.9.7/cms_pico-0.9.7.tar.gz
+ sha256sums = 041c87abb1932f25aaae65b998e873bd343213c0160ff873c91f24b70389e9cf
+
+pkgname = nextcloud-app-picocms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb07ee03c6e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sven Klomp <mail at klomp dot eu>
+
+pkgdesc='Allows to create a website as a subfolder of the cloud.'
+pkgname=('nextcloud-app-picocms')
+pkgver=0.9.7
+pkgrel=1
+arch=('any')
+license=('AGPL')
+url="https://github.com/nextcloud/cms_pico"
+makedepends=()
+depends=('nextcloud')
+options=('!strip')
+source=("cms_pico-${pkgver}.tar.gz::https://github.com/nextcloud/cms_pico/releases/download/v${pkgver}/cms_pico-${pkgver}.tar.gz")
+sha256sums=('041c87abb1932f25aaae65b998e873bd343213c0160ff873c91f24b70389e9cf')
+
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/cms_pico" "${pkgdir}/usr/share/webapps/nextcloud/apps/cms_pico"
+}
+