summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2019-05-19 17:49:32 -0400
committerHezekiah Michael2019-05-19 17:49:32 -0400
commitf86bc88a67af02709bde5c9e8f221e64b28529f2 (patch)
tree870cec12a0151041b4d2b9228a554dac20451a20
downloadaur-f86bc88a67af02709bde5c9e8f221e64b28529f2.tar.gz
Initial commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..11854bf0d4a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = nextcloud-app-theming-customcss
+ pkgdesc = Custom CSS support for Nextcloud servers
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/juliushaertl/theming_customcss
+ arch = any
+ license = AGPL
+ depends = nextcloud
+ options = !strip
+ source = theming_customcss-1.3.0::https://github.com/juliushaertl/theming_customcss/releases/download/v1.3.0/theming_customcss.tar.gz
+ md5sums = e65e5f39f696bd0df290011ceafcc7c8
+ sha256sums = c24a1e6bfa8c23eb6454e6305333b2511dc26617d17d097117eb1f220e4f3109
+
+pkgname = nextcloud-app-theming-customcss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a93d240037c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+pkgdesc='Custom CSS support for Nextcloud servers'
+pkgname=('nextcloud-app-theming-customcss')
+pkgver=1.3.0
+pkgrel=1
+arch=('any')
+license=('AGPL')
+url="https://github.com/juliushaertl/theming_customcss"
+makedepends=()
+depends=('nextcloud')
+options=('!strip')
+source=("theming_customcss-${pkgver}::https://github.com/juliushaertl/theming_customcss/releases/download/v${pkgver}/theming_customcss.tar.gz")
+
+sha256sums=('c24a1e6bfa8c23eb6454e6305333b2511dc26617d17d097117eb1f220e4f3109')
+md5sums=('e65e5f39f696bd0df290011ceafcc7c8')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/theming_customcss" "${pkgdir}/usr/share/webapps/nextcloud/apps/theming_customcss"
+}
+