summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2018-11-15 07:24:00 +0700
committerKonstantin Shalygin2018-11-15 07:24:00 +0700
commit1c86cbc65c90c2d9235f1489206b8143c18d70ce (patch)
tree0b092bb57e1f77f2febb35c472e809906776cbca
parent6dc96d879153220e026f464ed806c3e2f779eff6 (diff)
downloadaur-1c86cbc65c90c2d9235f1489206b8143c18d70ce.tar.gz
Make kio as opdependency again.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69ad3c3c43de..a7d006b3ff19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Nov 14 10:05:52 UTC 2018
+# Thu Nov 15 00:23:29 UTC 2018
pkgbase = nextcloud-client
pkgdesc = Nextcloud desktop client
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://nextcloud.com/
arch = i686
arch = x86_64
@@ -12,11 +12,12 @@ pkgbase = nextcloud-client
makedepends = python-sphinx
makedepends = qt5-tools
makedepends = doxygen
+ makedepends = kio
depends = qt5-webengine
depends = qtkeychain
- depends = kio
optdepends = python2-nautilus: integration with Nautilus
optdepends = nemo-python: integration with Nemo
+ optdepends = kio: Resource and network access abstraction (KDE)
optdepends = libgnome-keyring: GNOME keyring client
conflicts = owncloud-client
backup = etc/Nextcloud/sync-exclude.lst
diff --git a/PKGBUILD b/PKGBUILD
index 0060a9ef6e01..581cc80f5ccc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgname='nextcloud-client'
pkgver='2.5.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Nextcloud desktop client'
arch=('i686' 'x86_64')
url='https://nextcloud.com/'
license=('GPL2')
-depends=('qt5-webengine' 'qtkeychain' 'kio')
-makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen')
+depends=('qt5-webengine' 'qtkeychain')
+makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen' 'kio')
optdepends=('python2-nautilus: integration with Nautilus'
'nemo-python: integration with Nemo'
+ 'kio: Resource and network access abstraction (KDE)'
'libgnome-keyring: GNOME keyring client')
conflicts=('owncloud-client')
source=("https://github.com/nextcloud/desktop/archive/v${pkgver}.tar.gz")
@@ -26,10 +27,9 @@ build() {
cd "${srcdir}/desktop-${pkgver}/build"
cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr
make
make doc-man
}