summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKonstantin Shalygin2016-08-24 11:15:58 +0700
committerKonstantin Shalygin2016-08-24 11:15:58 +0700
commitfcf02821acd1b583d9084fff4c767fa02d940ee8 (patch)
tree50beca13ec05932ee82187e65b5fd14d93a51d99
downloadaur-fcf02821acd1b583d9084fff4c767fa02d940ee8.tar.gz
Initial commit.
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cef5ca50de5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Wed Aug 24 04:14:19 UTC 2016
+pkgbase = nextcloud-client
+ pkgdesc = Nextcloud desktop client
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = https://nextcloud.com
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ makedepends = python-sphinx
+ makedepends = qt5-tools
+ makedepends = doxygen
+ makedepends = kio
+ depends = qtkeychain
+ depends = qt5-webkit
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ optdepends = python2-nautilus: integration with Nautilus
+ optdepends = nemo-python: integration with Nemo
+ backup = etc/Nextcloud/sync-exclude.lst
+ source = nextcloud-client::git+https://github.com/nextcloud/client_theming.git
+ sha256sums = SKIP
+
+pkgname = nextcloud-client
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0ffb22392bce
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/*
+src/*
+*.tar.*
+nextcloud-client/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9604058e404b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Konstantin Shalygin <k0ste@k0ste.ru>
+# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
+
+pkgname='nextcloud-client'
+pkgver='2.2.3'
+pkgrel='1'
+pkgdesc="Nextcloud desktop client"
+arch=('i686' 'x86_64')
+url="https://nextcloud.com"
+license=('GPL2')
+depends=('qtkeychain' 'qt5-webkit' 'hicolor-icon-theme' 'xdg-utils')
+makedepends=('extra-cmake-modules' 'python-sphinx' 'qt5-tools' 'doxygen' 'kio')
+optdepends=('python2-nautilus: integration with Nautilus' 'nemo-python: integration with Nemo')
+source=("${pkgname}::git+https://github.com/nextcloud/client_theming.git")
+sha256sums=('SKIP')
+backup=('etc/Nextcloud/sync-exclude.lst')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git submodule update --init
+ cd client
+ git submodule update --init
+
+ mkdir "${srcdir}/${pkgname}/build-linux"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}/build-linux"
+
+ cmake -D OEM_THEME_DIR=${srcdir}/${pkgname}/nextcloudtheme ../client \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname}
+
+ make
+ make doc-man
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build-linux"
+ make DESTDIR="${pkgdir}" install
+}