summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Dence2018-06-17 12:30:11 -0400
committerTyler Dence2018-06-17 12:30:11 -0400
commitb57385dc697e2b2c7ac22116b9287d1263d412b0 (patch)
tree2a6b21282158cfa3da170792a3655f28ee1816f3
downloadaur-b57385dc697e2b2c7ac22116b9287d1263d412b0.tar.gz
Created nextcloud-desktop-git package
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD43
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e7c836d03c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = nextcloud-desktop-git
+ pkgdesc = Nextcloud desktop client
+ pkgver = 2.3.3
+ pkgrel = 1
+ url = https://nextcloud.com/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = qtkeychain
+ depends = qt5-webkit
+ depends = hicolor-icon-theme
+ depends = xdg-utils
+ depends = qt5-webengine
+ optdepends = python2-nautilus: integration with Nautilus
+ optdepends = nemo-python: integration with Nemo
+ provides = nextcloud-client
+ conflicts = mirall-git
+ conflicts = owncloud-client
+ conflicts = owncloud-client-ngs
+ conflicts = owncloud-client-git
+ conflicts = nextcloud-client
+ conflicts = nextcloud-client-git
+ conflicts = nextcloud-desktop
+ source = nextcloud-desktop-git::git+https://github.com/nextcloud/desktop.git
+ sha256sums = SKIP
+
+pkgname = nextcloud-desktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..260e49a7a4d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Tyler Dence <tyzoid@archlinux32.org>
+
+pkgname=nextcloud-desktop-git
+pkgver='2.3.3'
+pkgrel='1'
+pkgdesc='Nextcloud desktop client'
+arch=('i686' 'x86_64')
+url='https://nextcloud.com/'
+license=('GPL2')
+makedepends=('cmake' 'qt5-tools')
+depends=('qtkeychain' 'qt5-webkit' 'hicolor-icon-theme' 'xdg-utils' 'qt5-webengine')
+optdepends=(
+ 'python2-nautilus: integration with Nautilus'
+ 'nemo-python: integration with Nemo'
+)
+conflicts=('mirall-git' 'owncloud-client' 'owncloud-client-ngs' 'owncloud-client-git' 'nextcloud-client' 'nextcloud-client-git' 'nextcloud-desktop')
+provides=('nextcloud-client')
+source=("${pkgname}::git+https://github.com/nextcloud/desktop.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname";
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g';
+}
+
+build() {
+ cd "${srcdir}/${pkgname}";
+
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE="Release" \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc/${pkgname} \
+ -DWITH_DOC=FALSE \
+ .;
+
+ make;
+}
+
+package() {
+ cd "${srcdir}/${pkgname}";
+ make DESTDIR="${pkgdir}" install
+}