summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-15 16:18:32 +0200
committerGoliathLabs2020-05-15 16:18:32 +0200
commit44cefcfedfc1e6cc40a123e3a90eefd160608d7a (patch)
tree3f06bab3ebaf02f53bac62d225dc8a0346eb5607
parent7cedf3c06c396b1319d7b7fe660bcfee74acb234 (diff)
downloadaur-44cefcfedfc1e6cc40a123e3a90eefd160608d7a.tar.gz
Updated: PKGBUILD
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--apache.example.conf1
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6488b07b2a5..de62926108a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Dec 2 11:08:57 UTC 2017
pkgbase = nextcloud-git
pkgdesc = A cloud server to store your files centrally on a hardware controlled by you
- pkgver = 13.0.0beta1.r182.gcec236f0af
+ pkgver = 19.0.0RC2.r21.gf80f2a22d7
pkgrel = 1
url = https://nextcloud.com
arch = any
license = AGPL
- depends = php-gd
optdepends = php-apache: to use the Apache web server
optdepends = php-sqlite: to use the SQLite database backend
optdepends = php-pgsql: to use the PostgreSQL database backend
optdepends = php-ldap: LDAP authentication
optdepends = php-intl
optdepends = php-apcu
- optdepends = php-xcache
optdepends = mariadb: to use the MySQL database backend
optdepends = smbclient: to mount SAMBA shares
optdepends = php-mcrypt
@@ -40,6 +36,7 @@ pkgbase = nextcloud-git
source = git+https://github.com/nextcloud/apps.git
source = apache.example.conf
source = nextcloud.hook
+ validpgpkeys = 28806A878AE423A28372792ED75899B9A724937A
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -54,8 +51,11 @@ pkgbase = nextcloud-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 55b892adb86a67c2fa12d79f0980c6aea75aed5c6f6f78f2c2b5e5575a012067
+ sha256sums = 30a8ad62b0dc9523ca7f0387b1f0483d196c1e011ec7e3a5b98e7d33c721d4bf
sha256sums = d084cd6423c03f98087884b3c7b81f9510d1bea6c518860b64787a7f976cf0d3
pkgname = nextcloud-git
+ depends = php>=7.4.0
+ depends = php<7.5.0
+ depends = php-gd
diff --git a/PKGBUILD b/PKGBUILD
index bf3eb82a279f..3acde5ba3ddf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# $Id$
-# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
# Contributor: Jonas Heinrich <onny@project-insanity.org>
# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=nextcloud-git
_pkgname=nextcloud
-pkgver=13.0.0beta1.r182.gcec236f0af
+pkgver=19.0.0RC2.r21.gf80f2a22d7
pkgrel=1
pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
arch=('any')
url="https://nextcloud.com"
license=('AGPL')
-depends=('php-gd')
optdepends=('php-apache: to use the Apache web server'
'php-sqlite: to use the SQLite database backend'
'php-pgsql: to use the PostgreSQL database backend'
'php-ldap: LDAP authentication'
'php-intl'
'php-apcu'
- 'php-xcache'
'mariadb: to use the MySQL database backend'
'smbclient: to mount SAMBA shares'
'php-mcrypt'
@@ -59,7 +57,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '55b892adb86a67c2fa12d79f0980c6aea75aed5c6f6f78f2c2b5e5575a012067'
+ '30a8ad62b0dc9523ca7f0387b1f0483d196c1e011ec7e3a5b98e7d33c721d4bf'
'd084cd6423c03f98087884b3c7b81f9510d1bea6c518860b64787a7f976cf0d3')
pkgver() {
@@ -86,6 +84,8 @@ prepare() {
}
package() {
+ depends=('php>=7.4.0' 'php<7.5.0' 'php-gd')
+
# install project
install -d "$pkgdir"/usr/share/webapps/
cp -R "$srcdir"/server "$pkgdir"/usr/share/webapps/${_pkgname}
diff --git a/apache.example.conf b/apache.example.conf
index 306dd5c6f949..2c6e2f7b92f2 100644
--- a/apache.example.conf
+++ b/apache.example.conf
@@ -6,7 +6,6 @@
Options FollowSymlinks
AllowOverride all
Require all granted
- php_admin_value open_basedir "/srv/http/:/dev/urandom:/tmp/:/usr/share/pear/:/usr/share/webapps/nextcloud/:/etc/webapps/nextcloud"
</Directory>
<VirtualHost *:80>