summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-11-19 13:12:59 +0100
committerJonas Heinrich2017-11-19 13:12:59 +0100
commit608e09493ee411080d615818cdae4ea4587fac90 (patch)
treee1654d994583de61a33783ee8297d2aaa4a8088e
downloadaur-608e09493ee411080d615818cdae4ea4587fac90.tar.gz
first commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD66
-rw-r--r--apache.example.conf18
-rw-r--r--nextcloud.hook13
4 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef7c80da9546
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Sun Nov 19 12:10:57 UTC 2017
+pkgbase = nextcloud-git
+ pkgdesc = A cloud server to store your files centrally on a hardware controlled by you
+ pkgver = v13.0.0beta1.r42.gdd5373795f
+ pkgrel = 1
+ url = https://nextcloud.com
+ arch = any
+ license = AGPL
+ depends = php-gd
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = php-ldap: LDAP authentication
+ optdepends = php-intl
+ optdepends = php-apcu
+ optdepends = php-xcache
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = php-mcrypt
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ provides = nextcloud
+ conflicts = nextcloud
+ options = !strip
+ backup = etc/webapps/nextcloud/apache.example.conf
+ source = git+https://github.com/nextcloud/server.git
+ source = apache.example.conf
+ source = nextcloud.hook
+ sha256sums = SKIP
+ sha256sums = 55b892adb86a67c2fa12d79f0980c6aea75aed5c6f6f78f2c2b5e5575a012067
+ sha256sums = d084cd6423c03f98087884b3c7b81f9510d1bea6c518860b64787a7f976cf0d3
+
+pkgname = nextcloud-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eda4982920de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id$
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
+
+pkgname=nextcloud-git
+_pkgname=nextcloud
+pkgver=v13.0.0beta1.r42.gdd5373795f
+pkgrel=1
+pkgdesc="A cloud server to store your files centrally on a hardware controlled by you"
+arch=('any')
+url="https://nextcloud.com"
+license=('AGPL')
+depends=('php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu'
+ 'php-xcache'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+options=('!strip')
+provides=('nextcloud')
+conflicts=('nextcloud')
+backup=('etc/webapps/nextcloud/apache.example.conf')
+validpgpkeys=('28806A878AE423A28372792ED75899B9A724937A')
+source=('git+https://github.com/nextcloud/server.git'
+ 'apache.example.conf'
+ 'nextcloud.hook')
+sha256sums=('SKIP'
+ '55b892adb86a67c2fa12d79f0980c6aea75aed5c6f6f78f2c2b5e5575a012067'
+ 'd084cd6423c03f98087884b3c7b81f9510d1bea6c518860b64787a7f976cf0d3')
+
+pkgver() {
+ cd "server"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ # install project
+ install -d "$pkgdir"/usr/share/webapps/
+ cp -R "$srcdir"/server "$pkgdir"/usr/share/webapps/${_pkgname}
+
+ # install apache config file
+ install -d "$pkgdir"/etc/webapps/${_pkgname}
+ install -m 644 "$srcdir"/apache.example.conf "$pkgdir"/etc/webapps/${_pkgname}
+
+ # move config to /etc
+ install -d "$pkgdir"/etc/webapps/${_pkgname}
+ mv "$pkgdir"/usr/share/webapps/${_pkgname}/config "$pkgdir"/etc/webapps/${_pkgname}/config
+ chown -R http:http "$pkgdir"/etc/webapps/${_pkgname}
+ ln -s /etc/webapps/${_pkgname}/config "$pkgdir"/usr/share/webapps/${_pkgname}/config
+ chown -R root:http "$pkgdir"/usr/share/webapps/${_pkgname}
+
+ find "$pkgdir"/usr/share/webapps/${_pkgname} -type f -exec chmod 0644 {} \;
+ find "$pkgdir"/usr/share/webapps/${_pkgname} -type d -exec chmod 0755 {} \;
+
+ chmod a+x "$pkgdir"/usr/share/webapps/${_pkgname}/occ
+
+# install -Dm0644 "$srcdir"/nextcloud.hook "$pkgdir"/usr/share/libalpm/hooks/nextcloud.hook
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..306dd5c6f949
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,18 @@
+<IfModule mod_alias.c>
+ Alias /nextcloud /usr/share/webapps/nextcloud/
+</IfModule>
+
+<Directory /usr/share/webapps/nextcloud/>
+ Options FollowSymlinks
+ AllowOverride all
+ Require all granted
+ php_admin_value open_basedir "/srv/http/:/dev/urandom:/tmp/:/usr/share/pear/:/usr/share/webapps/nextcloud/:/etc/webapps/nextcloud"
+</Directory>
+
+<VirtualHost *:80>
+ ServerAdmin foo@foofarm.com
+ DocumentRoot /usr/share/webapps/nextcloud
+ ServerName nextcloud.foo.com
+ ErrorLog /var/log/httpd/nextcloud.foo.info-error_log
+ CustomLog /var/log/httpd/nextcloud.foo.info-access_log common
+</VirtualHost>
diff --git a/nextcloud.hook b/nextcloud.hook
new file mode 100644
index 000000000000..0d02056688bb
--- /dev/null
+++ b/nextcloud.hook
@@ -0,0 +1,13 @@
+# Update Nextcloud when core or -apps are touched
+
+[Trigger]
+Operation = Install
+Operation = Upgrade
+Type = Package
+Target = nextcloud
+Target = nextcloud-app-*
+
+[Action]
+Description = Updating Nextcloud installation
+When = PostTransaction
+Exec = /usr/bin/runuser -u http -- /usr/bin/php /usr/share/webapps/nextcloud/occ upgrade