summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2020-10-09 13:48:47 +0000
committerJonas Heinrich2020-10-09 13:48:47 +0000
commit2a054ecabc01789aef3f25bf1653ed9df051c384 (patch)
treefa57305f26fb7d58354f37210ae2f104ef0a13a7
downloadaur-2a054ecabc01789aef3f25bf1653ed9df051c384.tar.gz
init at 0.0.3
-rw-r--r--.SRCINFO14
-rwxr-xr-xPKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b662461625e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nextcloud-integration-reddit
+ pkgdesc = Reddit integration into Nextcloud
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/nextcloud/integration_reddit
+ arch = any
+ license = AGPL3
+ depends = nextcloud
+ options = !strip
+ source = https://github.com/nextcloud/integration_reddit/releases/download/v0.0.3/integration_reddit-0.0.3.tar.gz
+ sha512sums = 8772d6030cebc38a76439631069191ea50115ffe6d8be51825e9b41ade6e4b676afdb240ad5a65377334d07726031b05475a1ae5e7210a9bf70dbd77329e76e4
+
+pkgname = nextcloud-integration-reddit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3314911209d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=nextcloud-integration-reddit
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="Reddit integration into Nextcloud"
+arch=('any')
+url="https://github.com/nextcloud/integration_reddit"
+license=('AGPL3')
+depends=('nextcloud')
+makedepends=()
+options=('!strip')
+source=("https://github.com/nextcloud/integration_reddit/releases/download/v${pkgver}/integration_reddit-${pkgver}.tar.gz")
+sha512sums=('8772d6030cebc38a76439631069191ea50115ffe6d8be51825e9b41ade6e4b676afdb240ad5a65377334d07726031b05475a1ae5e7210a9bf70dbd77329e76e4')
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ cp -a "${srcdir}/integration_reddit" "${pkgdir}/usr/share/webapps/nextcloud/apps/integration_reddit"
+}