summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDominik Schrempf2018-08-05 13:19:52 +0200
committerDominik Schrempf2018-08-05 13:19:52 +0200
commit235a7b45186bdc373c1256ccd9550ca56c4d6ccd (patch)
tree308f9b7f5ce2426064d0ac8f71346b4e70ed835e
parentaf2c15f20e3dfc788b91eb0c040ef4046141d336 (diff)
downloadaur-235a7b45186bdc373c1256ccd9550ca56c4d6ccd.tar.gz
Install message.
-rw-r--r--PKGBUILD2
-rw-r--r--nextcloud-systemd-cron.install41
2 files changed, 42 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbbe95be5e8b..6e5d1c3f5009 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ replaces=()
backup=()
options=()
install=
-changelog=
+changelog="nextcloud-systemd-cron.install"
source=("nextcloudcron.service"
"nextcloudcron.timer")
md5sums=('95d8686b2480f1ab73ba5ccd7f672fae'
diff --git a/nextcloud-systemd-cron.install b/nextcloud-systemd-cron.install
new file mode 100644
index 000000000000..3650ae45389f
--- /dev/null
+++ b/nextcloud-systemd-cron.install
@@ -0,0 +1,41 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ # do something here
+ echo "Activate the timer with"
+ echo '$ systemctl daemon-reload'
+ echo '$ systemctl start nextcloudcron.timer'
+ echo '$ systemctl enable nextcloudcron.timer'
+ echo 'Check if timer is activated with'
+ echo '$ systemctl list-timers'
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}