summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatth@arch2024-02-10 18:07:00 +0100
committermatth@arch2024-02-10 18:07:00 +0100
commit9511fdf9323858bddf9d78ee94489046e5084eab (patch)
tree22fd910df4658cee129a74030ffbe9c8b1c39cf3
downloadaur-9511fdf9323858bddf9d78ee94489046e5084eab.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD52
-rw-r--r--nextcloud-talk.desktop8
-rw-r--r--nextcloud-talk.pngbin0 -> 3238 bytes
-rw-r--r--nextcloud-talk.svg69
5 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ad1a62b7a90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nextcloud-talk-desktop-bin
+ pkgdesc = Nextcloud Talk Desktop client based on Nextcloud Talk web application bundling
+ pkgver = 0.21.0
+ pkgrel = 1
+ url = https://github.com/nextcloud/talk-desktop
+ arch = x86_64
+ license = AGPL-3.0-only
+ provides = nextcloud-talk-dekstop
+ source = https://github.com/nextcloud-releases/talk-desktop/releases/download/v0.21.0/Nextcloud.Talk-linux-x64-0.21.0.zip
+ source = nextcloud-talk.svg
+ source = nextcloud-talk.png
+ source = nextcloud-talk.desktop
+ sha256sums = cf4ad50a47086c590a7ca7d479578f9d2212d29445f013ab896e864857bc1023
+ sha256sums = c657fd6071464318bc63ea09844470efc3d4210f179ed2deb8efee53052dac44
+ sha256sums = 8be5aed4243e7e25d46f41d68ebf7b3f85ebc4925e98391ad7e55fa98f2b83cb
+ sha256sums = 6da300342f6802ec1328c488b1c4786b87a462c9d2cc05b0ff55b1a03fbf32eb
+
+pkgname = nextcloud-talk-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e61104392c07
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Matthias Quintern <matthias.quintern(at)posteo.de>
+
+pkgname=nextcloud-talk-desktop-bin
+_pkgname=nextcloud-talk-desktop
+pkgver=0.21.0
+pkgrel=1
+pkgdesc="Nextcloud Talk Desktop client based on Nextcloud Talk web application bundling"
+arch=('x86_64')
+url="https://github.com/nextcloud/talk-desktop"
+license=('AGPL-3.0-only')
+provides=('nextcloud-talk-dekstop')
+
+depends=()
+optdepends=()
+_archivename="${pkgname}-${pkgver}.zip"
+source=(https://github.com/nextcloud-releases/talk-desktop/releases/download/v${pkgver}/Nextcloud.Talk-linux-x64-${pkgver}.zip
+ 'nextcloud-talk.svg'
+ 'nextcloud-talk.png'
+ 'nextcloud-talk.desktop')
+ # nextcloud-talk.svg::'https://github.com/nextcloud/talk-desktop/blob/main/img/talk-icon-rounded.svg'
+
+
+sha256sums=('cf4ad50a47086c590a7ca7d479578f9d2212d29445f013ab896e864857bc1023'
+ 'c657fd6071464318bc63ea09844470efc3d4210f179ed2deb8efee53052dac44'
+ '8be5aed4243e7e25d46f41d68ebf7b3f85ebc4925e98391ad7e55fa98f2b83cb'
+ '6da300342f6802ec1328c488b1c4786b87a462c9d2cc05b0ff55b1a03fbf32eb')
+
+prepare() {
+ # Avoid file name with space in /opt
+ mv "${srcdir}/Nextcloud Talk-linux-x64/Nextcloud Talk" "${srcdir}/Nextcloud Talk-linux-x64/nextcloud-talk"
+}
+
+package() {
+ install -d "${pkgdir}/opt/"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/share/pixmaps"
+
+ # Archive contents
+ mv "${srcdir}/Nextcloud Talk-linux-x64" "${pkgdir}/opt/${_pkgname}"
+ chmod 0755 "${pkgdir}/opt/${_pkgname}"
+
+ # Symlink in /usr/bin
+ ln -s "/opt/nextcloud-talk-desktop/nextcloud-talk" "${pkgdir}/usr/bin/nextcloud-talk"
+
+ # Icons
+ install -m644 "${srcdir}/nextcloud-talk.svg" "${pkgdir}/usr/share/pixmaps/nextcloud-talk.svg"
+ install -m644 "${srcdir}/nextcloud-talk.png" "${pkgdir}/usr/share/pixmaps/nextcloud-talk.png"
+
+ # Desktop Entry
+ install -m644 "${srcdir}/nextcloud-talk.desktop" "${pkgdir}/usr/share/applications/nextcloud-talk.desktop"
+}
diff --git a/nextcloud-talk.desktop b/nextcloud-talk.desktop
new file mode 100644
index 000000000000..e4bbac85c03c
--- /dev/null
+++ b/nextcloud-talk.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Nextcloud Talk
+Comment=Nextcloud Talk Desktop Client
+Exec=/opt/nextcloud-talk-desktop/nextcloud-talk
+Icon=nextcloud-talk
+Terminal=false
+Type=Application
+Categories=AudioVideo Network VideoConference Chat
diff --git a/nextcloud-talk.png b/nextcloud-talk.png
new file mode 100644
index 000000000000..f35bfc277dcf
--- /dev/null
+++ b/nextcloud-talk.png
Binary files differ
diff --git a/nextcloud-talk.svg b/nextcloud-talk.svg
new file mode 100644
index 000000000000..28a7ec7f94bf
--- /dev/null
+++ b/nextcloud-talk.svg
@@ -0,0 +1,69 @@
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<svg
+ xmlns:dc="http://purl.org/dc/elements/1.1/"
+ xmlns:cc="http://creativecommons.org/ns#"
+ xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
+ xmlns:svg="http://www.w3.org/2000/svg"
+ xmlns="http://www.w3.org/2000/svg"
+ xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
+ xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
+ inkscape:version="1.1-dev (f9311a1, 2019-12-25)"
+ sodipodi:docname="talk8.svg"
+ id="svg19"
+ xml:space="preserve"
+ viewBox="0 0 1024 1024"
+ version="1.1"
+ stroke-miterlimit="1.4142"
+ stroke-linejoin="round"
+ fill-rule="evenodd"
+ clip-rule="evenodd"><metadata
+ id="metadata23"><rdf:RDF><cc:Work
+ rdf:about=""><dc:format>image/svg+xml</dc:format><dc:type
+ rdf:resource="http://purl.org/dc/dcmitype/StillImage" /><dc:title></dc:title></cc:Work></rdf:RDF></metadata><sodipodi:namedview
+ inkscape:current-layer="svg19"
+ inkscape:window-maximized="1"
+ inkscape:window-y="23"
+ inkscape:window-x="1440"
+ inkscape:cy="522.40348"
+ inkscape:cx="510.51379"
+ inkscape:zoom="0.67285156"
+ showgrid="false"
+ id="namedview21"
+ inkscape:window-height="1035"
+ inkscape:window-width="1920"
+ inkscape:pageshadow="2"
+ inkscape:pageopacity="0"
+ guidetolerance="10"
+ gridtolerance="10"
+ objecttolerance="10"
+ borderopacity="1"
+ inkscape:document-rotation="0"
+ bordercolor="#666666"
+ pagecolor="#ffffff" /><defs
+ id="defs15"><linearGradient
+ gradientUnits="userSpaceOnUse"
+ gradientTransform="matrix(8.96 0 0 8.96 -7.8457e-5 .00019795)"
+ y2="-7.6294e-6"
+ y1="150"
+ x2="150"
+ x1="18.23"
+ id="a"><stop
+ id="stop10"
+ offset="0"
+ stop-color="#0082c9" /><stop
+ id="stop12"
+ offset="1"
+ stop-color="#1cafff" /></linearGradient></defs>
+<rect
+ id="rect17"
+ fill-rule="evenodd"
+ fill="url(#a)"
+ height="1024"
+ width="1024"
+ rx="160" /><path
+ style="fill:#ffffff"
+ inkscape:connector-curvature="0"
+ d="M 511.95919,186 A 325.96385,325.95103 0 0 0 186,511.96034 325.96385,325.95103 0 0 0 511.95919,837.91133 325.96385,325.95103 0 0 0 681.04889,790.22529 c 40.06218,15.91895 129.79781,63.14682 151.15526,42.74701 22.3177,-21.31206 -26.20129,-121.61808 -37.83331,-158.89148 A 325.96385,325.95103 0 0 0 837.91466,511.95755 325.96385,325.95103 0 0 0 511.96013,186.01118 Z m 0.0373,123.92323 A 202.1178,202.11161 0 0 1 714.11425,512.03485 202.1178,202.11161 0 0 1 511.99645,714.13247 202.1178,202.11161 0 0 1 309.87866,512.03485 202.1178,202.11161 0 0 1 511.99645,309.92323 Z"
+ stroke-width="0.14"
+ fill="#000"
+ id="path25" /></svg>