summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-12-05 16:16:03 +0000
committerGrey Christoforo2016-12-05 16:16:03 +0000
commit6f179efe57d7489f1b2f28e1410689218edd2128 (patch)
treeffa3488019254a7715bc903469f842952072e393
downloadaur-6f179efe57d7489f1b2f28e1410689218edd2128.tar.gz
initial commit
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD61
-rw-r--r--apache.example.conf15
-rwxr-xr-xset-nc-perms.sh63
5 files changed, 186 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c09c38deb63a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,39 @@
+# Generated by mksrcinfo v8
+# Mon Dec 5 16:15:59 UTC 2016
+pkgbase = nextcloud-testing
+ pkgdesc = Testing Release -- A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way
+ pkgver = 11.0.0beta2
+ pkgrel = 1
+ url = https://nextcloud.com
+ arch = any
+ license = AGPL
+ depends = php
+ depends = php-gd
+ optdepends = php-apache: to use the Apache web server
+ optdepends = php-sqlite: to use the SQLite database backend
+ optdepends = php-pgsql: to use the PostgreSQL database backend
+ optdepends = php-ldap: LDAP authentication
+ optdepends = php-intl
+ optdepends = php-apcu
+ optdepends = mariadb: to use the MySQL database backend
+ optdepends = smbclient: to mount SAMBA shares
+ optdepends = php-mcrypt
+ optdepends = imagemagick: file preview
+ optdepends = ffmpeg: file preview
+ optdepends = libreoffice: file preview
+ provides = nextcloud
+ conflicts = owncloud
+ conflicts = nextcloud
+ options = !strip
+ options = emptydirs
+ source = https://download.nextcloud.com/server/prereleases/nextcloud-11.0.0beta2.tar.bz2
+ source = https://download.nextcloud.com/server/prereleases/nextcloud-11.0.0beta2.tar.bz2.asc
+ source = apache.example.conf
+ source = set-nc-perms.sh
+ md5sums = 0ca765c16b1d34e7e263f7226abbc96b
+ md5sums = SKIP
+ md5sums = bc2b02b0562b7a58e660e33acd4202bc
+ md5sums = d505daefdb3c0ef5c9ca6ea8973d7c17
+
+pkgname = nextcloud-testing
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..41c065c69192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*.tar.bz2
+*.asc
+*.pkg.tar.xz
+*.patch
+*.pkg.tar
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..975d0932d247
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=nextcloud-testing
+pkgver=11.0.0beta2
+pkgrel=1
+pkgdesc="Testing Release -- A safe home for all your data. Secure, under your control and developed in an open, transparent and trustworthy way"
+url="https://nextcloud.com"
+arch=('any')
+provides=('nextcloud')
+conflicts=('owncloud' 'nextcloud')
+license=('AGPL')
+depends=('php' 'php-gd')
+optdepends=('php-apache: to use the Apache web server'
+ 'php-sqlite: to use the SQLite database backend'
+ 'php-pgsql: to use the PostgreSQL database backend'
+ 'php-ldap: LDAP authentication'
+ 'php-intl'
+ 'php-apcu'
+ 'mariadb: to use the MySQL database backend'
+ 'smbclient: to mount SAMBA shares'
+ 'php-mcrypt'
+ 'imagemagick: file preview'
+ 'ffmpeg: file preview'
+ 'libreoffice: file preview')
+options=('!strip')
+validpgpkeys=('28806A878AE423A28372792ED75899B9A724937A')
+source=("https://download.nextcloud.com/server/prereleases/nextcloud-${pkgver}.tar.bz2"{,.asc}
+ "apache.example.conf"
+ "set-nc-perms.sh")
+
+md5sums=('0ca765c16b1d34e7e263f7226abbc96b'
+ 'SKIP'
+ 'bc2b02b0562b7a58e660e33acd4202bc'
+ 'd505daefdb3c0ef5c9ca6ea8973d7c17')
+_fetchedMD5=$(curl -sS https://download.nextcloud.com/server/prereleases/nextcloud-${pkgver}.tar.bz2.md5)
+IFS=' '; _arrFetchedMD5=($_fetchedMD5); unset IFS;
+_fetchedMD5=${_arrFetchedMD5[0]}
+md5sums[0]=$_fetchedMD5
+
+options=(!strip emptydirs)
+
+#prepare() {
+# cd nextcloud-${pkgver}
+#}
+
+package() {
+ #install -d "${pkgdir}/usr/share/licenses/${pkgname}"
+ #cp "${srcdir}/nextcloud/COPYING-AGPL" "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ install -d "${pkgdir}/usr/share/webapps"
+ cp -r nextcloud "${pkgdir}/usr/share/webapps/."
+
+ # set the proper permissions
+ "${srcdir}/set-nc-perms.sh" runtime "${pkgdir}/usr/share/webapps/nextcloud"
+
+ install -D -m755 "${srcdir}/set-nc-perms.sh" "${pkgdir}/usr/bin/set-nc-perms"
+ install -m644 -D "${srcdir}/apache.example.conf" -t "${pkgdir}/etc/webapps/nextcloud"
+ ln -s /usr/share/webapps/nextcloud/occ "${pkgdir}/usr/bin/occ"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..84f452ac274c
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,15 @@
+Alias /nextcloud "/usr/share/webapps/nextcloud"
+
+<Directory /usr/share/webapps/nextcloud/>
+ Options +FollowSymlinks
+ AllowOverride All
+ Require all granted
+
+ <IfModule mod_dav.c>
+ Dav off
+ </IfModule>
+
+ SetEnv HOME /usr/share/webapps/nextcloud
+ SetEnv HTTP_HOME /usr/share/webapps/nextcloud
+
+</Directory>
diff --git a/set-nc-perms.sh b/set-nc-perms.sh
new file mode 100755
index 000000000000..6985d116f8dd
--- /dev/null
+++ b/set-nc-perms.sh
@@ -0,0 +1,63 @@
+#!/usr/bin/env bash
+# from https://docs.nextcloud.org/server/9/admin_manual/installation/installation_wizard.html#strong-perms-label
+# run with the argument "runtime" to set the proper runtime permissions
+# run with the argument "upgrade" to set the proper upgrade permissions
+
+if [ -z "$2" ]
+ then
+ ncpath='/usr/share/webapps/nextcloud'
+ else
+ ncpath="$2"
+fi
+
+htuser='http'
+htgroup='http'
+rootuser='root'
+
+runtime() {
+ printf "Creating possible missing Directories\n"
+ mkdir -p $ncpath/data
+ mkdir -p $ncpath/assets
+ mkdir -p $ncpath/updater
+
+ printf "chmod Files and Directories\n"
+ find ${ncpath}/ -type f -print0 | xargs -0 chmod 0640
+ find ${ncpath}/ -type d -print0 | xargs -0 chmod 0750
+
+ printf "chown Directories\n"
+ chown -R ${rootuser}:${htgroup} ${ncpath}/
+ chown -R ${htuser}:${htgroup} ${ncpath}/apps/
+ chown -R ${htuser}:${htgroup} ${ncpath}/assets/
+ chown -R ${htuser}:${htgroup} ${ncpath}/config/
+ chown -R ${htuser}:${htgroup} ${ncpath}/data/
+ chown -R ${htuser}:${htgroup} ${ncpath}/themes/
+ chown -R ${htuser}:${htgroup} ${ncpath}/updater/
+
+ chmod +x ${ncpath}/occ
+
+ printf "chmod/chown .htaccess\n"
+ if [ -f ${ncpath}/.htaccess ]
+ then
+ chmod 0664 ${ncpath}/.htaccess
+ chown ${rootuser}:${htgroup} ${ncpath}/.htaccess
+ fi
+ if [ -f ${ncpath}/data/.htaccess ]
+ then
+ chmod 0664 ${ncpath}/data/.htaccess
+ chown ${rootuser}:${htgroup} ${ncpath}/data/.htaccess
+ fi
+
+ printf "chmod/chown .user.ini\n"
+ if [ -f ${ncpath}/.user.ini ]
+ then
+ chmod 0664 ${ncpath}/.user.ini
+ chown ${rootuser}:${htgroup} ${ncpath}/.htaccess
+ fi
+}
+
+upgrade() {
+ printf "Setting upgrade permissions\n"
+ chown -R ${htuser}:${htgroup} ${ncpath}
+}
+
+$1