summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Lefranc2019-11-23 12:30:49 +0100
committerGuillaume Lefranc2019-11-23 12:30:49 +0100
commit01620129143824b282a85a7114892a0550e5747e (patch)
tree86d89ec99b1ecfdcbf087a15b4f933721a7a14f1
downloadaur-01620129143824b282a85a7114892a0550e5747e.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD25
-rw-r--r--nextdns.install8
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4710264754a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nextdns
+ pkgdesc = NextDNS DNS-over-HTTPS client
+ pkgver = 1.1.8
+ pkgrel = 1
+ url = https://github.com/nextdns/nextdns
+ install = nextdns.install
+ arch = x86_64
+ license = MIT
+ makedepends = go-pie
+ source = https://github.com/nextdns/nextdns/archive/v1.1.8.tar.gz
+ sha256sums = aceaa6108feb86f678e3a26e1d558e99799a8e62d5bccd1af3d2c98754a0c517
+
+pkgname = nextdns
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e570bc49abe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+*.gz
+*.log
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b9dd73b6986
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Lefranc <guillaume@signal18.io>
+pkgname=nextdns
+pkgver=1.1.8
+pkgrel=1
+pkgdesc='NextDNS DNS-over-HTTPS client'
+arch=('x86_64')
+url="https://github.com/nextdns/nextdns"
+license=('MIT')
+makedepends=('go-pie')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('aceaa6108feb86f678e3a26e1d558e99799a8e62d5bccd1af3d2c98754a0c517')
+install=$pkgname.install
+
+build() {
+ cd $pkgname-$pkgver
+ go build \
+ -trimpath \
+ -ldflags "-X main.version=$pkgver -extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname-$pkgver
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}
diff --git a/nextdns.install b/nextdns.install
new file mode 100644
index 000000000000..49496701a51e
--- /dev/null
+++ b/nextdns.install
@@ -0,0 +1,8 @@
+post_install() {
+ /usr/bin/nextdns install
+}
+
+pre_remove() {
+ systemctl stop nextdns
+ /usr/bin/nextdns uninstall
+}