summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-10-14 07:32:14 +1300
committercaltlgin2020-10-14 07:32:14 +1300
commit2f6a784d6c17abe6b0c05488f08b14356297165b (patch)
tree5106e94b92f467bfda68a6c34df31995953c35f6
downloadaur-2f6a784d6c17abe6b0c05488f08b14356297165b.tar.gz
Add to AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69305307d2ef
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nextinspace-git
+ pkgdesc = Print upcoming space-related events to your terminal
+ pkgver = 1.0.0.r7.g13e05ad
+ pkgrel = 1
+ url = https://github.com/The-Kid-Gid/nextinspace
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-colorama
+ depends = python-requests
+ depends = python-tzlocal
+ provides = nextinspace
+ conflicts = nextinspace
+ source = nextinspace::git+https://github.com/The-Kid-Gid/nextinspace.git
+ sha256sums = SKIP
+
+pkgname = nextinspace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8e8d33fd753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+_pkgname='nextinspace'
+pkgname="${_pkgname}-git"
+pkgver=1.0.0.r7.g13e05ad
+pkgrel=1
+pkgdesc='Print upcoming space-related events to your terminal'
+arch=('any')
+url='https://github.com/The-Kid-Gid/nextinspace'
+license=('GPL3')
+depends=('python-colorama' 'python-requests' 'python-tzlocal')
+makedepends=('git' 'python-setuptools')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${_pkgname}"
+}
+
+# vim: ts=2 sw=2 et: