summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAki Van Ness2024-04-11 08:13:13 +0200
committerAki Van Ness2024-04-11 08:13:13 +0200
commitedb4a8bed883898609ad406d5a94d6d3fabb5e55 (patch)
tree16940befbcb277351329e31ff1464ea9e5fbdb4e
parentb0312dbf2ff0b178626dc320a0d04240567b7043 (diff)
downloadaur-edb4a8bed883898609ad406d5a94d6d3fabb5e55.tar.gz
Bumpped nextpnr-all version to 20240411_nextpnr_0.7_26_gd3b53d8e
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD86
-rw-r--r--PKGBUILD.in86
3 files changed, 146 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bba24c89089..3b0f33986833 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nextpnr-all-nightly
- pkgdesc = nextpnr portable FPGA place and route tool - all FPGA architectures
- pkgver = 20230528_nextpnr_0.6_11_ge5a5de53
+ pkgdesc = nextpnr portable FPGA place and route tool - ice40, ecp5, machxo2, nexus, and generic
+ pkgver = 20240411_nextpnr_0.7_26_gd3b53d8e
pkgrel = 1
epoch = 1
url = https://github.com/YosysHQ/nextpnr
@@ -24,10 +24,11 @@ pkgbase = nextpnr-all-nightly
conflicts = nextpnr-git
conflicts = nextpnr-ice40-nightly
conflicts = nextpnr-ecp5-nightly
+ conflicts = nextpnr-machxo2-nightly
conflicts = nextpnr-nexus-nightly
conflicts = nextpnr-generic-nightly
options = !strip
- source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=e5a5de53
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=d3b53d8e
sha256sums = SKIP
pkgname = nextpnr-all-nightly
diff --git a/PKGBUILD b/PKGBUILD
index 7464999e705c..6ecd4159f43a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-all-nightly
-pkgver=20230528_nextpnr_0.6_11_ge5a5de53
+pkgver=20240411_nextpnr_0.7_26_gd3b53d8e
pkgrel=1
epoch=1
-pkgdesc="nextpnr portable FPGA place and route tool - all FPGA architectures"
+pkgdesc="nextpnr portable FPGA place and route tool - ice40, ecp5, machxo2, nexus, and generic"
arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
@@ -25,12 +25,13 @@ conflicts=(
"nextpnr-git"
"nextpnr-ice40-nightly"
"nextpnr-ecp5-nightly"
+ "nextpnr-machxo2-nightly"
"nextpnr-nexus-nightly"
"nextpnr-generic-nightly"
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=e5a5de53"
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=d3b53d8e"
)
sha256sums=(
"SKIP"
@@ -39,25 +40,80 @@ sha256sums=(
_PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
- [ ! -d "${srcdir}/nextpnr/build-all" ] && mkdir build-all
+ [ ! -d "${srcdir}/nextpnr/build-ice40" ] && mkdir build-ice40
+ [ ! -d "${srcdir}/nextpnr/build-ecp5" ] && mkdir build-ecp5
+ [ ! -d "${srcdir}/nextpnr/build-machxo2" ] && mkdir build-machxo2
+ [ ! -d "${srcdir}/nextpnr/build-nexus" ] && mkdir build-nexus
+ [ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
}
build() {
- cd "${srcdir}/nextpnr"
- cd build-all
- cmake -G Ninja \
- -DARCH=all \
- -DBUILD_PYTHON=ON \
- -DBUILD_GUI=ON \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
- -DUSE_OPENMP=ON \
- ..
+ cd "${srcdir}/nextpnr/build-ice40"
+ cmake -G Ninja \
+ -DARCH=ice40 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-ecp5"
+ cmake -G Ninja \
+ -DARCH=ecp5 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-machxo2"
+ cmake -G Ninja \
+ -DARCH=ecp5 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-nexus"
+ cmake -G Ninja \
+ -DARCH=nexus \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
ninja
+
+
+ cd "${srcdir}/nextpnr/build-generic"
+ cmake -G Ninja \
+ -DARCH=generic \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
}
package() {
cd "${srcdir}/nextpnr"
- DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-all install
+
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-ice40 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-ecp5 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-machxo2 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-nexus install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
+
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr/COPYING"
}
diff --git a/PKGBUILD.in b/PKGBUILD.in
index 9d00be26cc31..1ee9e442db32 100644
--- a/PKGBUILD.in
+++ b/PKGBUILD.in
@@ -1,10 +1,10 @@
# Maintainer: Aki-nyan <aur@catgirl.link>
pkgname=nextpnr-all-nightly
-pkgver=@NPR_VER@
+pkgver=@EDA_VER@
pkgrel=1
epoch=1
-pkgdesc="nextpnr portable FPGA place and route tool - all FPGA architectures"
+pkgdesc="nextpnr portable FPGA place and route tool - ice40, ecp5, machxo2, nexus, and generic"
arch=("x86_64")
url="https://github.com/YosysHQ/nextpnr"
license=("custom:ISC")
@@ -25,12 +25,13 @@ conflicts=(
"nextpnr-git"
"nextpnr-ice40-nightly"
"nextpnr-ecp5-nightly"
+ "nextpnr-machxo2-nightly"
"nextpnr-nexus-nightly"
"nextpnr-generic-nightly"
)
replaces=()
source=(
- "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=@NPR_HASH@"
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=@EDA_HASH@"
)
sha256sums=(
"SKIP"
@@ -39,25 +40,80 @@ sha256sums=(
_PREFIX="/usr"
prepare() {
cd "${srcdir}/nextpnr"
- [ ! -d "${srcdir}/nextpnr/build-all" ] && mkdir build-all
+ [ ! -d "${srcdir}/nextpnr/build-ice40" ] && mkdir build-ice40
+ [ ! -d "${srcdir}/nextpnr/build-ecp5" ] && mkdir build-ecp5
+ [ ! -d "${srcdir}/nextpnr/build-machxo2" ] && mkdir build-machxo2
+ [ ! -d "${srcdir}/nextpnr/build-nexus" ] && mkdir build-nexus
+ [ ! -d "${srcdir}/nextpnr/build-generic" ] && mkdir build-generic
}
build() {
- cd "${srcdir}/nextpnr"
- cd build-all
- cmake -G Ninja \
- -DARCH=all \
- -DBUILD_PYTHON=ON \
- -DBUILD_GUI=ON \
- -DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
- -DUSE_OPENMP=ON \
- ..
+ cd "${srcdir}/nextpnr/build-ice40"
+ cmake -G Ninja \
+ -DARCH=ice40 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-ecp5"
+ cmake -G Ninja \
+ -DARCH=ecp5 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-machxo2"
+ cmake -G Ninja \
+ -DARCH=ecp5 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
+ cd "${srcdir}/nextpnr/build-nexus"
+ cmake -G Ninja \
+ -DARCH=nexus \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
ninja
+
+
+ cd "${srcdir}/nextpnr/build-generic"
+ cmake -G Ninja \
+ -DARCH=generic \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+
}
package() {
cd "${srcdir}/nextpnr"
- DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-all install
+
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-ice40 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-ecp5 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-machxo2 install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-nexus install
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-generic install
+
install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr/COPYING"
}