summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraham Edgecombe2018-08-02 18:33:55 +0100
committerGraham Edgecombe2018-08-02 18:33:55 +0100
commit94fcb289511003824092f265ae4af14312e435fa (patch)
tree56129465f777486776fd808eca724d02ffb6c0a2
downloadaur-94fcb289511003824092f265ae4af14312e435fa.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD46
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea9034fc1511
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Thu Aug 2 17:33:49 UTC 2018
+pkgbase = nextpnr-git
+ pkgdesc = Portable FPGA place and route tool
+ pkgver = r1185.1c1fd99
+ pkgrel = 1
+ url = https://github.com/YosysHQ/nextpnr
+ arch = i686
+ arch = x86_64
+ license = ISC
+ makedepends = boost
+ makedepends = cmake
+ makedepends = git
+ makedepends = icestorm
+ depends = boost-libs
+ depends = python
+ depends = qt5-base
+ provides = nextpnr
+ conflicts = nextpnr
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git
+ sha256sums = SKIP
+
+pkgname = nextpnr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..41bf48d1db2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+.*
+*~
+*.tar*
+/nextpnr
+/pkg
+/src
+!.SRCINFO
+!.git*
+!.mailmap
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29f59b4f8a9d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Graham Edgecombe <gpe@grahamedgecombe.com>
+pkgname=nextpnr-git
+pkgver=r1185.1c1fd99
+pkgrel=1
+pkgdesc='Portable FPGA place and route tool'
+arch=('i686' 'x86_64')
+url='https://github.com/YosysHQ/nextpnr'
+license=('ISC')
+depends=('boost-libs' 'python' 'qt5-base')
+makedepends=('boost' 'cmake' 'git' 'icestorm')
+provides=('nextpnr')
+conflicts=('nextpnr')
+source=('nextpnr::git+https://github.com/YosysHQ/nextpnr.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/nextpnr"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/nextpnr"
+
+ mkdir -p build
+ cd build
+
+ cmake \
+ -DARCH=generic\;ice40 \
+ -DICEBOX_ROOT=/usr/share/icebox \
+ -DBUILD_TESTS=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ make
+}
+
+check() {
+ cd "$srcdir/nextpnr/build"
+ make test
+}
+
+package() {
+ cd "$srcdir/nextpnr/build"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}