summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAki Van Ness2024-04-11 08:13:29 +0200
committerAki Van Ness2024-04-11 08:13:29 +0200
commitea2723999036b928ced967a29d80885458507f2d (patch)
tree7e68246786730202dae03fce8443004e9e1e6082
downloadaur-ea2723999036b928ced967a29d80885458507f2d.tar.gz
Bumpped nextpnr-machxo2 version to 20240411_nextpnr_0.7_26_gd3b53d8e
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD58
-rw-r--r--PKGBUILD.in58
4 files changed, 149 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c25c82a682e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = nextpnr-machxo2-nightly
+ pkgdesc = nextpnr portable FPGA place and route tool - for machxo2
+ pkgver = 20240411_nextpnr_0.7_26_gd3b53d8e
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/YosysHQ/nextpnr
+ arch = x86_64
+ license = custom:ISC
+ makedepends = git
+ makedepends = gcc
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = pkgconf
+ makedepends = gawk
+ makedepends = eigen
+ makedepends = boost
+ depends = yosys-nightly
+ depends = prjtrellis-nightly
+ depends = python
+ depends = boost-libs
+ depends = qt5-base
+ conflicts = nextpnr-git
+ conflicts = nextpnr-all-nightly
+ options = !strip
+ source = nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=d3b53d8e
+ sha256sums = SKIP
+
+pkgname = nextpnr-machxo2-nightly
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff301b174ab6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!PKGBUILD
+!PKGBUILD.in
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f41207b5adc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=nextpnr-machxo2-nightly
+pkgver=20240411_nextpnr_0.7_26_gd3b53d8e
+pkgrel=1
+epoch=1
+pkgdesc="nextpnr portable FPGA place and route tool - for machxo2"
+arch=("x86_64")
+url="https://github.com/YosysHQ/nextpnr"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=(
+ "yosys-nightly"
+ "prjtrellis-nightly"
+ "python"
+ "boost-libs"
+ "qt5-base"
+)
+optdepends=()
+makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen" "boost")
+conflicts=(
+ "nextpnr-git"
+ "nextpnr-all-nightly"
+)
+replaces=()
+source=(
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=d3b53d8e"
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+prepare() {
+ cd "${srcdir}/nextpnr"
+ [ ! -d "${srcdir}/nextpnr/build-machxo2" ] && mkdir build-machxo2
+}
+
+build() {
+ cd "${srcdir}/nextpnr"
+ cd build-machxo2
+ cmake -G Ninja \
+ -DARCH=machxo2 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+}
+
+package() {
+ cd "${srcdir}/nextpnr"
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-machxo2 install
+ install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-machxo2/COPYING"
+}
diff --git a/PKGBUILD.in b/PKGBUILD.in
new file mode 100644
index 000000000000..4aa46af6fbb3
--- /dev/null
+++ b/PKGBUILD.in
@@ -0,0 +1,58 @@
+# Maintainer: Aki-nyan <aur@catgirl.link>
+
+pkgname=nextpnr-machxo2-nightly
+pkgver=@EDA_VER@
+pkgrel=1
+epoch=1
+pkgdesc="nextpnr portable FPGA place and route tool - for machxo2"
+arch=("x86_64")
+url="https://github.com/YosysHQ/nextpnr"
+license=("custom:ISC")
+groups=()
+options=("!strip")
+depends=(
+ "yosys-nightly"
+ "prjtrellis-nightly"
+ "python"
+ "boost-libs"
+ "qt5-base"
+)
+optdepends=()
+makedepends=("git" "gcc" "cmake" "ninja" "pkgconf" "gawk" "eigen" "boost")
+conflicts=(
+ "nextpnr-git"
+ "nextpnr-all-nightly"
+)
+replaces=()
+source=(
+ "nextpnr::git+https://github.com/YosysHQ/nextpnr.git#commit=@EDA_HASH@"
+)
+sha256sums=(
+ "SKIP"
+)
+
+_PREFIX="/usr"
+prepare() {
+ cd "${srcdir}/nextpnr"
+ [ ! -d "${srcdir}/nextpnr/build-machxo2" ] && mkdir build-machxo2
+}
+
+build() {
+ cd "${srcdir}/nextpnr"
+ cd build-machxo2
+ cmake -G Ninja \
+ -DARCH=machxo2 \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_GUI=ON \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=${_PREFIX} \
+ -DUSE_OPENMP=ON \
+ ..
+ ninja
+}
+
+package() {
+ cd "${srcdir}/nextpnr"
+ DESTDIR="${pkgdir}" PREFIX="${_PREFIX}" ninja -C build-machxo2 install
+ install -Dm644 "${srcdir}/nextpnr/COPYING" "${pkgdir}${_PREFIX}/share/licenses/nextpnr-machxo2/COPYING"
+}