summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave Shoreman2019-03-26 00:54:48 +0000
committerDave Shoreman2019-03-26 00:54:48 +0000
commit0c05f3a87fca7e7b763ffa793a88563c1bfa5e5b (patch)
treefb95c5b1b8d7908bebfa74bcd340b95fbde9f45f
parent71d6db1cf58d9b4452afd387b71e50c4d5173e28 (diff)
downloadaur-0c05f3a87fca7e7b763ffa793a88563c1bfa5e5b.tar.gz
Update for v1.0.0
Bumps version, switches to using Makefile, adds --deps note in .install
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--nextshot.install15
3 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9454e5c23d1..27f6d2c51641 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,23 @@
pkgbase = nextshot
pkgdesc = A simple screenshot tool that uploads to Nextcloud and works with Sway and X11
- pkgver = 0.8.2
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/dshoreman/nextshot
+ install = nextshot.install
arch = x86_64
license = GPL
depends = bash
depends = curl
+ depends = jq
optdepends = yad: tray icon and gui support
optdepends = grim: take screenshots on Sway
- optdepends = jq: window selection on Sway
optdepends = slurp: area selection on Sway
optdepends = wl-clipboard: clipboard support on Sway
optdepends = imagemagick: take screenshots on X11
optdepends = slop: window/area selection on X11
optdepends = xclip: clipboard support on X11
- source = https://github.com/dshoreman/nextshot/archive/v0.8.2.tar.gz
- md5sums = b4b1ab471694b251d38fd2a3a7a459be
+ source = https://github.com/dshoreman/nextshot/archive/v1.0.0.tar.gz
+ md5sums = e0454d101d5a93dbb07674813b436b40
pkgname = nextshot
diff --git a/PKGBUILD b/PKGBUILD
index 570fccb77eee..03a53ecca40c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,27 @@
# Maintainer: Dave Shoreman <aur+nextshot at dsdev dot io>
pkgname=nextshot
-pkgver=0.8.2
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="A simple screenshot tool that uploads to Nextcloud and works with Sway and X11"
arch=('x86_64')
url="https://github.com/dshoreman/nextshot"
license=('GPL')
-depends=('bash' 'curl')
+depends=('bash' 'curl' 'jq')
optdepends=(
"yad: tray icon and gui support"
"grim: take screenshots on Sway"
- "jq: window selection on Sway"
"slurp: area selection on Sway"
"wl-clipboard: clipboard support on Sway"
"imagemagick: take screenshots on X11"
"slop: window/area selection on X11"
"xclip: clipboard support on X11"
)
-source=(https://github.com/dshoreman/nextshot/archive/v0.8.2.tar.gz)
-md5sums=('b4b1ab471694b251d38fd2a3a7a459be')
-
+install=nextshot.install
+source=(https://github.com/dshoreman/nextshot/archive/v${pkgver}.tar.gz)
+md5sums=('e0454d101d5a93dbb07674813b436b40')
package() {
cd "$pkgname-$pkgver"
- mkdir -p "$pkgdir/usr/bin"
- cp -p nextshot.sh "$pkgdir/usr/bin/nextshot"
+ make DESTDIR="$pkgdir/" install
}
diff --git a/nextshot.install b/nextshot.install
new file mode 100644
index 000000000000..746b9b86cb9a
--- /dev/null
+++ b/nextshot.install
@@ -0,0 +1,15 @@
+#!/usr/bin/env bash
+
+readonly info=$'\e[36m'
+readonly warn=$'\e[33m'
+readonly reset=$'\e[0m'
+
+post_install() {
+ echo "${info}Thanks for installing Nextshot!"
+ echo "${warn}Dependencies vary based on your current environment."
+ echo "Run 'nextshot --deps' after configuration to ensure you have all required packages.${reset}"
+}
+
+post_upgrade() {
+ post_install "$1"
+}