summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2023-06-16 12:26:58 +0800
committerYour Name2023-06-16 12:26:58 +0800
commit9f4c765bb0d2815cf8707d1456df1ba35a9ef967 (patch)
treeace80fc842318de899e6556549cc5f495f8e7d62
parent994bf23e37bb8fa709ccb90f4c02f84d3343f03f (diff)
downloadaur-9f4c765bb0d2815cf8707d1456df1ba35a9ef967.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 974f53dfc31b..6d174e3a570e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nexttrace
pkgdesc = An open source visual route tracking CLI tool
- pkgver = 1.1.5
+ pkgver = 1.1.7
pkgrel = 1
- url = https://github.com/sjlleo/nexttrace
+ url = https://github.com/sjlleo/nexttrace-core
install = nexttrace.install
arch = x86_64
license = GPL
makedepends = go
makedepends = git
- source = git+https://github.com/sjlleo/nexttrace.git#tag=v1.1.5
+ source = git+https://github.com/sjlleo/nexttrace-core.git#tag=v1.1.7
sha256sums = SKIP
pkgname = nexttrace
diff --git a/PKGBUILD b/PKGBUILD
index 49c84b8c379d..9a15309e94ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
pkgname=nexttrace
-pkgver=1.1.5
+pkgver=1.1.7
pkgrel=1
pkgdesc='An open source visual route tracking CLI tool'
arch=('x86_64')
-url="https://github.com/sjlleo/nexttrace"
+url="https://github.com/sjlleo/nexttrace-core"
license=('GPL')
makedepends=('go' 'git')
-source=("git+https://github.com/sjlleo/nexttrace.git#tag=v$pkgver")
+source=("git+https://github.com/sjlleo/nexttrace-core.git#tag=v$pkgver")
sha256sums=('SKIP')
install=nexttrace.install
build() {
- cd "$pkgname"
+ cd "nexttrace-core"
export BUILD_VERSION="$(git describe --tags --always)"
export COMMIT_SHA1="$(git rev-parse --short HEAD)"
go build \
@@ -19,11 +19,11 @@ build() {
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" -X 'github.com/xgadget-lab/nexttrace/printer.version=${BUILD_VERSION}' -X 'github.com/xgadget-lab/nexttrace/printer.commitID=${COMMIT_SHA1}' " \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" -X 'github.com/xgadget-lab/nexttrace/config.Version=${BUILD_VERSION}' -X 'github.com/xgadget-lab/nexttrace/config.CommitID=${COMMIT_SHA1}' " \
.
}
package() {
- cd "$pkgname"
+ cd "nexttrace-core"
install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
}