summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2023-11-08 22:58:36 +0800
committerYour Name2023-11-08 22:58:36 +0800
commitad81dbc695981967df306640284c8c1f99807f1a (patch)
tree49946ecfad5725a2b2c1bb3c55714a2d9065b167
parent9f4c765bb0d2815cf8707d1456df1ba35a9ef967 (diff)
downloadaur-ad81dbc695981967df306640284c8c1f99807f1a.tar.gz
update
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d174e3a570e..d62eca70d979 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = nexttrace
pkgdesc = An open source visual route tracking CLI tool
- pkgver = 1.1.7
+ pkgver = 1.2.4
pkgrel = 1
- url = https://github.com/sjlleo/nexttrace-core
+ url = https://github.com/nxtrace/NTrace-core
install = nexttrace.install
arch = x86_64
license = GPL
makedepends = go
makedepends = git
- source = git+https://github.com/sjlleo/nexttrace-core.git#tag=v1.1.7
+ source = git+https://github.com/nxtrace/NTrace-core.git#tag=v1.2.4
sha256sums = SKIP
pkgname = nexttrace
diff --git a/PKGBUILD b/PKGBUILD
index 9a15309e94ea..1a38e5c7a321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
pkgname=nexttrace
-pkgver=1.1.7
+pkgver=1.2.4
pkgrel=1
pkgdesc='An open source visual route tracking CLI tool'
arch=('x86_64')
-url="https://github.com/sjlleo/nexttrace-core"
+url="https://github.com/nxtrace/NTrace-core"
license=('GPL')
makedepends=('go' 'git')
-source=("git+https://github.com/sjlleo/nexttrace-core.git#tag=v$pkgver")
+source=("git+https://github.com/nxtrace/NTrace-core.git#tag=v$pkgver")
sha256sums=('SKIP')
install=nexttrace.install
build() {
- cd "nexttrace-core"
+ cd "NTrace-core"
export BUILD_VERSION="$(git describe --tags --always)"
export COMMIT_SHA1="$(git rev-parse --short HEAD)"
go build \
@@ -19,11 +19,12 @@ build() {
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" -X 'github.com/xgadget-lab/nexttrace/config.Version=${BUILD_VERSION}' -X 'github.com/xgadget-lab/nexttrace/config.CommitID=${COMMIT_SHA1}' " \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" -X 'github.com/nxtrace/NTrace-core/config.Version=${BUILD_VERSION}' -X 'github.com/nxtrace/NTrace-core/config.CommitID=${COMMIT_SHA1}' " \
.
}
package() {
- cd "nexttrace-core"
- install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+ cd "NTrace-core"
+ install -Dm755 NTrace-core "$pkgdir"/usr/bin/$pkgname
+ setcap cap_net_raw,cap_net_admin+eip "$pkgdir"/usr/bin/$pkgname
}