summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2018-09-16 20:17:52 +0200
committerSefa Eyeoglu2018-09-16 20:17:52 +0200
commit6c1a4c120e45db6bc6cef62ad4e287e6c53e6380 (patch)
tree2e4cc33ab074c9bcb8be6aedfcd9e3f8ab156ee5
downloadaur-6c1a4c120e45db6bc6cef62ad4e287e6c53e6380.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
-rw-r--r--nfancurve.install18
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d9ca9ff033d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nfancurve
+ pkgdesc = A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs
+ pkgver = 016
+ pkgrel = 1
+ url = https://github.com/nan0s7/nfancurve
+ install = nfancurve.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ depends = nvidia
+ depends = nvidia-settings
+ depends = procps
+ conflicts = nfancurve-git
+ source = nfancurve-016::https://github.com/nan0s7/nfancurve/archive/v016.tar.gz
+ sha512sums = 98a47ec6e8a8131b6dac2b287fb33577440457a11a4ea28a9fd53ec8568416776d3ec4bf37741ccdc06522b39ada876fe14c8829263802433d3dda3814558c98
+
+pkgname = nfancurve
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52bf9c681b73
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=nfancurve
+pkgname=${_pkgname}
+pkgver=016
+pkgrel=1
+pkgdesc="A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs"
+arch=("any")
+
+url="https://github.com/nan0s7/nfancurve"
+license=("GPL3")
+
+depends=("bash" "nvidia" "nvidia-settings" "procps")
+makedepends=("git")
+conflicts=("${_pkgname}-git")
+
+install=${_pkgname}.install
+
+source=(
+ "${_pkgname}-${pkgver}::https://github.com/nan0s7/${_pkgname}/archive/v${pkgver}.tar.gz"
+)
+sha512sums=(
+ "98a47ec6e8a8131b6dac2b287fb33577440457a11a4ea28a9fd53ec8568416776d3ec4bf37741ccdc06522b39ada876fe14c8829263802433d3dda3814558c98"
+)
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+
+ install -m755 -D "temp.sh" "$pkgdir/usr/bin/nfancurve"
+ install -m644 -D "config.sh" "$pkgdir/usr/share/doc/${_pkgname}/config.sh.example"
+}
diff --git a/nfancurve.install b/nfancurve.install
new file mode 100644
index 000000000000..31d2c533d38f
--- /dev/null
+++ b/nfancurve.install
@@ -0,0 +1,18 @@
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "You will need to create a config file to use nfancurve."
+ note "An example config can be found at /usr/share/doc/nfancurve/config.sh.example"
+}
+
+post_upgrade() {
+ post_install
+}