summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2018-09-16 20:25:11 +0200
committerSefa Eyeoglu2018-09-16 20:25:11 +0200
commit1432e200315d3de21d469d445e50fe125405d0bd (patch)
tree76a95e2a2922b5b645250639debb40ce65a05272
downloadaur-1432e200315d3de21d469d445e50fe125405d0bd.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
-rw-r--r--nfancurve.install18
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9aa0e5177b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nfancurve-git
+ pkgdesc = A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs
+ pkgver = v016.r12.gea6fcf8
+ pkgrel = 1
+ url = https://github.com/nan0s7/nfancurve
+ install = nfancurve.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ depends = nvidia
+ depends = nvidia-settings
+ depends = procps
+ conflicts = nfancurve-git
+ source = nfancurve::git+https://github.com/nan0s7/nfancurve.git
+ sha512sums = SKIP
+
+pkgname = nfancurve-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..58d0156262ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=nfancurve
+pkgname=${_pkgname}-git
+pkgver=v016.r12.gea6fcf8
+pkgrel=1
+pkgdesc="A small and lightweight Bash script for using a custom fan curve in Linux for NVIDIA GPUs"
+arch=("any")
+
+url="https://github.com/nan0s7/nfancurve"
+license=("GPL3")
+
+depends=("bash" "nvidia" "nvidia-settings" "procps")
+makedepends=("git")
+conflicts=("${_pkgname}-git")
+
+install=${_pkgname}.install
+
+source=(
+ "${_pkgname}::git+https://github.com/nan0s7/${_pkgname}.git"
+)
+sha512sums=(
+ "SKIP"
+)
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_pkgname}"
+
+ install -m755 -D "temp.sh" "$pkgdir/usr/bin/nfancurve"
+ install -m644 -D "config" "$pkgdir/usr/share/doc/${_pkgname}/config.example"
+}
diff --git a/nfancurve.install b/nfancurve.install
new file mode 100644
index 000000000000..31d2c533d38f
--- /dev/null
+++ b/nfancurve.install
@@ -0,0 +1,18 @@
+# Colored makepkg-like functions
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "You will need to create a config file to use nfancurve."
+ note "An example config can be found at /usr/share/doc/nfancurve/config.sh.example"
+}
+
+post_upgrade() {
+ post_install
+}