summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas18182021-02-25 18:38:45 +0100
committerLukas18182021-02-25 18:38:45 +0100
commitc52c409a46bdca330846d1c7bf6388d83efc535b (patch)
tree437872541e63303af49cfe5412f4d80046417f4b
parent04941f10c7c588f630c7404a03f61bba755298cd (diff)
downloadaur-c52c409a46bdca330846d1c7bf6388d83efc535b.tar.gz
update to 1.1.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35368dc6ade8..6e511973d2c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = nfauthenticationkey
pkgdesc = create a Netflix authentican Key, which can be used for the Neflix Kodi addon or somewhere else.
- pkgver = 1.1.1
+ pkgver = 1.1.3
pkgrel = 1
url = https://github.com/CastagnaIT/NFAuthenticationKey/tree/linux
arch = any
license = GPL3
makedepends = sed
- depends = chromium
+ depends = nfauthenticationkey-browser
depends = python
depends = python-pycryptodomex
depends = python-websocket-client
- source = NFAuthenticationKey-Linux-1.1.1.tar.gz::https://github.com/CastagnaIT/NFAuthenticationKey/archive/4b1a2dca26b553e4b782b1799d4889058e0ed799.tar.gz
- sha512sums = df8a81309ec365b5dfcd7bcc423578a7c541e48b043fc13eb3d9dfbc82a9263d86381e6bed7ce8448c8248a65a3e06334b95cae1ad23c0d2504fc4e4a1bbe13d
+ source = NFAuthenticationKey-Linux-1.1.3.tar.gz::https://github.com/CastagnaIT/NFAuthenticationKey/archive/eef806798f0b211dd87cdb1f949956801a812eb7.tar.gz
+ sha512sums = 639203cf05bb2c71b7ad7aa21e129b01b89ac91578aa59ad2aa31a8601b07ceb82854201207b2cc501e4a0c16ee188b61f2e1b507e63b72ca55f75ccd991730d
pkgname = nfauthenticationkey
diff --git a/PKGBUILD b/PKGBUILD
index 2b8f64a61b6a..9385bca970d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Lukas1818 aur at lukas1818 dot de
pkgname=nfauthenticationkey
-commit=4b1a2dca26b553e4b782b1799d4889058e0ed799
-pkgver=1.1.1
-_pkgtag=$pkgver
+_commit=eef806798f0b211dd87cdb1f949956801a812eb7
+pkgver=1.1.3
pkgrel=1
arch=('any')
pkgdesc="create a Netflix authentican Key, which can be used for the Neflix Kodi addon or somewhere else."
url="https://github.com/CastagnaIT/NFAuthenticationKey/tree/linux"
license=('GPL3')
makedepends=('sed')
-depends=('chromium' 'python' 'python-pycryptodomex' 'python-websocket-client')
-source=("NFAuthenticationKey-Linux-$pkgver.tar.gz::https://github.com/CastagnaIT/NFAuthenticationKey/archive/$commit.tar.gz")
-sha512sums=('df8a81309ec365b5dfcd7bcc423578a7c541e48b043fc13eb3d9dfbc82a9263d86381e6bed7ce8448c8248a65a3e06334b95cae1ad23c0d2504fc4e4a1bbe13d')
+depends=('nfauthenticationkey-browser' 'python' 'python-pycryptodomex' 'python-websocket-client')
+source=("NFAuthenticationKey-Linux-$pkgver.tar.gz::https://github.com/CastagnaIT/NFAuthenticationKey/archive/$_commit.tar.gz")
+sha512sums=('639203cf05bb2c71b7ad7aa21e129b01b89ac91578aa59ad2aa31a8601b07ceb82854201207b2cc501e4a0c16ee188b61f2e1b507e63b72ca55f75ccd991730d')
prepare()
{
- sed -i '1i #!/usr/bin/python' "$srcdir/NFAuthenticationKey-$commit/NFAuthenticationKey.py"
+ sed -i '1i #!/usr/bin/python' "$srcdir/NFAuthenticationKey-$_commit/NFAuthenticationKey.py"
}
package()
{
- install -Dm 755 "${srcdir}/NFAuthenticationKey-$commit/NFAuthenticationKey.py" "${pkgdir}/usr/bin/nfauthenticationkey"
+ install -Dm 755 "${srcdir}/NFAuthenticationKey-$_commit/NFAuthenticationKey.py" "${pkgdir}/usr/bin/nfauthenticationkey"
}