summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuke2022-05-22 01:02:12 -0500
committerLuke2022-05-22 01:02:12 -0500
commit1234964295c33d0127ccc70b8468541c194358f0 (patch)
tree09715faa880fedb31c59324945adae65e62abe3b
downloadaur-1234964295c33d0127ccc70b8468541c194358f0.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34b617f68a27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nfetch-bin
+ pkgdesc = A minimal linux fetch utility written in nim
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://github.com/Infinitybeond1/nfetch-src
+ arch = x86_64
+ license = GPL3
+ makedepends = nim
+ makedepends = nimble
+ conflicts = nfetch-bin
+ source = nfetch-src-1.00::https://github.com/Infinitybeond1/nfetch-src/archive/refs/tags/nfetch.tar.gz
+ sha256sums = 6bf668a334f0053a907e0c7c594bc68fa5e0ab06d40147367e235e05fc32010d
+
+pkgname = nfetch-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee625340405c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+pkgname='nfetch-bin'
+pkgdesc="A minimal linux fetch utility written in nim"
+pkgver=1.00
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/Infinitybeond1/nfetch-src"
+license=('GPL3')
+source=("nfetch-src-$pkgver::https://github.com/Infinitybeond1/nfetch-src/archive/refs/tags/nfetch.tar.gz")
+makedepends=('nim' 'nimble')
+conflicts=('nfetch-bin')
+sha256sums=('6bf668a334f0053a907e0c7c594bc68fa5e0ab06d40147367e235e05fc32010d')
+
+package() {
+ wget "https://github.com/Infinitybeond1/nfetch-src/archive/refs/tags/nfetch.tar.gz"
+ tar xvf nfetch.tar.gz
+ cd nfetch-src-nfetch
+ nimble build
+ sudo install nfetch /usr/bin
+}