summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-12-18 17:59:10 +0100
committerFabioLolix2022-12-18 17:59:10 +0100
commitdc2d091772f6bbd7f2e65876f32317e783469862 (patch)
tree6a94e4aad90d041ab4e6e92c24dd27aefe626f26
parent801e036d33ac63377daf17ee60c01e8e60df748c (diff)
downloadaur-dc2d091772f6bbd7f2e65876f32317e783469862.tar.gz
revision
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 28 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7911d2009c14..bf11dc1891c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = nfetch-git
pkgdesc = A minimal linux fetch utility written in nim
- pkgver = 2.61
- pkgrel = 0
+ pkgver = 2.r19.g2655d63
+ pkgrel = 1
url = https://github.com/Infinitybeond1/nfetch-src
arch = x86_64
license = GPL3
makedepends = nim
makedepends = nimble
- conflicts = nfetch-bin
- source = git+https://github.com/Infinitybeond1/nfetch-src
+ makedepends = git
+ provides = nfetch
+ conflicts = nfetch
+ source = git+https://github.com/Infinitybeond1/nfetch-src.git
sha256sums = SKIP
pkgname = nfetch-git
diff --git a/PKGBUILD b/PKGBUILD
index bf85772610a8..f56655745043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,32 @@
-pkgname='nfetch-git'
+# Maintainer:
+# Contributor: Fabio 'Lolix' Loli <lolix@disroot.org>
+# Contributor: Luke <Infinitybeond1@protonmail.com>
+
+pkgname=nfetch-git
pkgdesc="A minimal linux fetch utility written in nim"
-pkgver=2.61
-pkgrel=0
-arch=('x86_64')
+pkgver=2.r19.g2655d63
+pkgrel=1
+arch=(x86_64)
url="https://github.com/Infinitybeond1/nfetch-src"
-license=('GPL3')
-source=("git+https://github.com/Infinitybeond1/nfetch-src")
-makedepends=('nim' 'nimble')
-conflicts=('nfetch-bin')
+license=(GPL3)
+makedepends=(nim nimble git)
+provides=(nfetch)
+conflicts=(nfetch)
+source=("git+https://github.com/Infinitybeond1/nfetch-src.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "nfetch-src"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
build() {
- cd nfetch-src
+ cd "nfetch-src"
nimble build
}
package() {
- cd nfetch-src
- sudo install nfetch "/usr/local/bin"
+ cd "nfetch-src"
+ install -D nfetch -t "${pkgdir}/usr/bin/"
+ install -D config.ini -t "${pkgdir}/usr/share/doc/nfetch"
}