summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Zardi2022-12-07 14:50:12 +0100
committerFrancesco Zardi2022-12-07 14:50:12 +0100
commit9cd4a2378a68402d448318a576b366d44ddd02b9 (patch)
tree69c593d35619707159c04f94eba8d2e15b498ba1
parent42f1f453ad4a8ddb083b563ac55cde28c9079ca5 (diff)
downloadaur-9cd4a2378a68402d448318a576b366d44ddd02b9.tar.gz
Run bootstrap.sh before build, check all cd, run tests
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a9675f4bd9c..2b01db40e9a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,12 +16,26 @@ source=("https://github.com/NFFT/nfft/releases/download/$pkgver/$pkgname-$pkgver
sha256sums=('cf3b2f3b2eabd79e49a5fbabf7f8d73fc3c57c4f68ae71e29f6dead853ab2901')
build() {
- cd "$pkgname-$pkgver"
- ./configure --prefix=/usr --enable-all --enable-openmp
- make
+ cd "$pkgname-$pkgver" || exit 1
+
+ ./bootstrap.sh
+
+ ./configure \
+ --prefix=/usr \
+ --enable-all \
+ --enable-openmp
+
+ make
}
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname-$pkgver" || exit 1
+
make DESTDIR="$pkgdir/" install
}
+
+check() {
+
+ cd "$pkgname-$pkgver" || exit 1
+ make check
+}