summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2022-05-09 23:25:01 +0200
committerAndrea Feletto2022-05-09 23:25:01 +0200
commit9f0c9cd3d1e7a6a19bb089428ed00d04fd8341d3 (patch)
tree08e7aaa0e3efc610475e7a74c0c1e111e4850c1e
downloadaur-9f0c9cd3d1e7a6a19bb089428ed00d04fd8341d3.tar.gz
first commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a56e25a6a41c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = nfm-git
+ pkgdesc = Neat terminal file manager.
+ pkgver = r132.1048d2d
+ pkgrel = 1
+ url = https://sr.ht/~leon_plickat/nfm
+ arch = x86_64
+ license = GPL3
+ makedepends = zig
+ makedepends = git
+ provides = nfm
+ conflicts = nfm
+ source = git+https://git.sr.ht/~leon_plickat/nfm
+ source = git+https://github.com/tiehuis/zig-regex
+ source = git+https://git.sr.ht/~leon_plickat/zig-spoon
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = nfm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8af1aab31919
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=nfm-git
+_pkgname=${pkgname%-*}
+pkgver=r132.1048d2d
+pkgrel=1
+pkgdesc='Neat terminal file manager.'
+arch=('x86_64')
+url='https://sr.ht/~leon_plickat/nfm'
+license=('GPL3')
+makedepends=('zig' 'git')
+provides=('nfm')
+conflicts=('nfm')
+source=(
+ "git+https://git.sr.ht/~leon_plickat/nfm"
+ 'git+https://github.com/tiehuis/zig-regex'
+ 'git+https://git.sr.ht/~leon_plickat/zig-spoon'
+)
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+)
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ for dep in regex spoon; do
+ git config "submodule.deps/zig-$dep.url" "$srcdir/zig-$dep"
+ done
+ git submodule update
+}
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ DESTDIR="$pkgdir" zig build -Drelease-safe --prefix '/usr'
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+}