summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernandez Ludovic2021-12-31 03:06:44 +0100
committerFernandez Ludovic2021-12-31 03:06:44 +0100
commitaebebe06ef0932f246929767ad983a857d8a8538 (patch)
treede4029c13d32a06ce97700e7802db8826e8bdcd9
downloadaur-aebebe06ef0932f246929767ad983a857d8a8538.tar.gz
feat: v2.11.3
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9337e8522587
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = nfpm-bin
+ pkgdesc = A simple deb and rpm packager written in Go
+ pkgver = v2.11.3
+ pkgrel = 1
+ url = https://github.com/goreleaser/nfpm
+ arch = x86_64
+ license = MIT
+ provides = nfpm
+ conflicts = nfpm
+ source = https://github.com/goreleaser/nfpm/releases/download/v2.11.3/nfpm_2.11.3_linux_x86_64.tar.gz
+ sha256sums = da82e726e83b39481e79b160262cf700750ca8b15a62f7bcb65d587f65f508fc
+
+pkgname = nfpm-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62c168149636
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Fernandez Ludovic <lfernandez dot dev at gmail dot com>
+
+pkgname='nfpm-bin'
+_pkgname="${pkgname%-bin}"
+pkgver=v2.11.3
+pkgrel=1
+pkgdesc='A simple deb and rpm packager written in Go '
+url='https://github.com/goreleaser/nfpm'
+arch=('x86_64')
+license=('MIT')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+depends=()
+makedepends=()
+
+_basedownloadurl="${url}/releases/download/v${pkgver#v}"
+
+source=("${_basedownloadurl}/${_pkgname}_${pkgver#v}_linux_${arch}.tar.gz")
+sha256sums=('da82e726e83b39481e79b160262cf700750ca8b15a62f7bcb65d587f65f508fc')
+
+package() {
+ # Bin
+ rm -f "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # License
+ install -Dm644 "${srcdir}/LICENSE.md" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+}