summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricebal2018-11-16 08:12:20 -0600
committericebal2018-11-16 08:12:20 -0600
commit96c4f8b014cad3f7d1a134c5c20a5441d06731d8 (patch)
tree34a39869d4d9ee78bb51bac4e3423cc6189ad999
parent4c24955d36c876f65dde08e161e07a70921cbb70 (diff)
downloadaur-96c4f8b014cad3f7d1a134c5c20a5441d06731d8.tar.gz
updated to 2.7.1, and added proper DBUS support
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae0ede242806..7b3d1825bafc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
-# Generated by mksrcinfo v8
-# Fri Jan 19 11:16:50 UTC 2018
pkgbase = nfs-ganesha
pkgdesc = NFS-Ganesha supports both the NFS and 9P protocols in user mode.
- pkgver = 2.6.2
+ pkgver = 2.7.1
pkgrel = 1
url = http://nfs-ganesha.github.io/
- arch = i686
- arch = x86_64
+ arch = any
license = GPL3
makedepends = cmake
makedepends = gcc
makedepends = bison
makedepends = flex
+ conflicts = nfs-ganesha-git
backup = etc/ganesha/ganesha.conf
backup = etc/sysconfig/ganesha
- source = git://github.com/nfs-ganesha/nfs-ganesha.git#commit=b9685b89acb5a21db2a44a6b5bf5d85709e98b7d
- md5sums = SKIP
+ source = nfs-ganesha::https://github.com/nfs-ganesha/nfs-ganesha/archive/V$pkgver.tar.gz
+ sha256sums = ebe4c5ee4caafe435b6beeee17cc587d7c3cb3473003f5e786f9101ac457342f
pkgname = nfs-ganesha
+
diff --git a/PKGBUILD b/PKGBUILD
index 8dfd6c7268bb..a0a465ff5e5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
-# Maintainer: Oliver Mangold <o.mangold@gmail.com>
+# Maintainer: Wes Jackson <icebal dot 7 at gmail dot com>
pkgname=nfs-ganesha
-pkgver=2.6.2
+pkgver=2.7.1
pkgrel=1
pkgdesc="NFS-Ganesha supports both the NFS and 9P protocols in user mode."
-arch=('i686' 'x86_64')
+arch=('any')
url="http://nfs-ganesha.github.io/"
license=('GPL3')
depends=()
+conflicts=('nfs-ganesha-git')
makedepends=('cmake' 'gcc' 'bison' 'flex')
-source=('git://github.com/nfs-ganesha/nfs-ganesha.git#commit=b9685b89acb5a21db2a44a6b5bf5d85709e98b7d')
-md5sums=('SKIP')
+source=("$pkgname"::'https://github.com/nfs-ganesha/nfs-ganesha/archive/V$pkgver.tar.gz')
+sha256sums=('ebe4c5ee4caafe435b6beeee17cc587d7c3cb3473003f5e786f9101ac457342f')
backup=(etc/ganesha/ganesha.conf etc/sysconfig/ganesha)
prepare() {
- cd "${pkgname}"
- git submodule update --init
+ cd "${pkgname}"
+ git submodule update --init
}
-
build() {
cd "${pkgname}"
- cmake src/ -DUSE_9P=ON -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=/usr/lib
+ cmake src/ -DUSE_9P=ON -DCMAKE_BUILD_TYPE=Maintainer -DBUILD_CONFIG=everything -DLIB_INSTALL_DIR=/usr/lib
make
}
@@ -31,7 +31,11 @@ package() {
mv "$pkgdir"/var/run "$pkgdir"/run
rmdir "$pkgdir"/var
install -d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/etc/sysconfig "$pkgdir"/usr/libexec/ganesha
- install src/scripts/systemd/*.service "$pkgdir"/usr/lib/systemd/system
+ install src/scripts/ganeshactl/org.ganesha.nfsd.conf "$pkgdir"/etc/dbus-1/system.d/
+ install src/scripts/systemd/nfs-ganesha.service.el7 "$pkgdir"/usr/lib/systemd/system/nfs-ganesha.service
+ install src/scripts/systemd/nfs-ganesha-lock.service.el7 "$pkgdir"/usr/lib/systemd/system/nfs-ganesha-lock.service
+ install src/scripts/systemd/nfs-ganesha-config.service-in.cmake "$pkgdir"/usr/lib/systemd/system/nfs-ganesha-config.service
install src/scripts/systemd/sysconfig/nfs-ganesha "$pkgdir"/etc/sysconfig/ganesha
+ install src/scripts/systemd/tmpfiles.d/ganesha.conf "$pkgdir"/etc/tmpfiles.d/ganesha.conf
install src/scripts/nfs-ganesha-config.sh "$pkgdir"/usr/libexec/ganesha
}