summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoricebal2018-08-28 14:24:03 -0500
committericebal2018-08-28 14:24:03 -0500
commit6060b32b0483b5cfbd9fc1b716a2db546b3ca522 (patch)
treeead5289d183cad3323746e308c2a90bd67414082
parentd1f8803cdbd4be017a92efe2e4b71c90b95c1a53 (diff)
downloadaur-6060b32b0483b5cfbd9fc1b716a2db546b3ca522.tar.gz
fixed service files, and added 9P
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9cc0c94022fd..ff0936df1cb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
+# Maintainer: Wes Jackson <icebal dot 7 at gmail dot com>
pkgname=nfs-ganesha-git
-pkgver=11231.2e2b8e659
+pkgver=11870.32e8a2462
pkgrel=1
pkgdesc="Nfs-ganesha supports both the NFS and 9P protocols."
arch=('any')
url="http://nfs-ganesha.github.io/"
license=('GPL3')
depends=()
+conflicts=('nfs-ganesha')
makedepends=('git' 'cmake' 'gcc' 'bison' 'flex')
source=("$pkgname"::'git://github.com/nfs-ganesha/nfs-ganesha.git')
md5sums=('SKIP')
@@ -16,7 +17,7 @@ backup=(etc/ganesha/ganesha.conf etc/sysconfig/ganesha)
pkgver() {
cd ${pkgname}
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
@@ -26,7 +27,7 @@ prepare() {
build() {
cd "${pkgname}"
- cmake src/ -DUSE_9P=OFF -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=/usr/lib
+ cmake src/ -DUSE_9P=ON -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=/usr/lib
make
}
@@ -36,7 +37,8 @@ package() {
mv "$pkgdir"/var/run "$pkgdir"/run
rmdir "$pkgdir"/var
install -d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/etc/sysconfig "$pkgdir"/usr/libexec/ganesha
- install src/scripts/systemd/*.service "$pkgdir"/usr/lib/systemd/system
+ install src/scripts/systemd/nfs-ganesha.service.el7 "$pkgdir"/usr/lib/systemd/system/nfs-ganesha.service
+ install src/scripts/systemd/nfs-ganesha-config.service-in.cmake "$pkgdir"/usr/lib/systemd/system/nfs-ganesha-config.service
install src/scripts/systemd/sysconfig/nfs-ganesha "$pkgdir"/etc/sysconfig/ganesha
install src/scripts/nfs-ganesha-config.sh "$pkgdir"/usr/libexec/ganesha
}