summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimofey Titovets2017-09-13 19:58:49 +0300
committerTimofey Titovets2017-09-13 19:58:49 +0300
commitd1f8803cdbd4be017a92efe2e4b71c90b95c1a53 (patch)
tree8ae98a4d7e0f355f7f1a6e09350a05b689bd2cfc
parent52dc33f9c9166249f712b3687558bed1cb8ab9bc (diff)
downloadaur-d1f8803cdbd4be017a92efe2e4b71c90b95c1a53.tar.gz
Update
Signed-off-by: Timofey Titovets <nefelim4ag@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df7b7dd9b9e8..560a5cda4904 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Mar 14 15:55:28 UTC 2017
+# Wed Sep 13 16:58:44 UTC 2017
pkgbase = nfs-ganesha-git
pkgdesc = Nfs-ganesha supports both the NFS and 9P protocols.
- pkgver = 10720.437cb6711
+ pkgver = 11231.2e2b8e659
pkgrel = 1
url = http://nfs-ganesha.github.io/
arch = any
@@ -12,6 +12,8 @@ pkgbase = nfs-ganesha-git
makedepends = gcc
makedepends = bison
makedepends = flex
+ backup = etc/ganesha/ganesha.conf
+ backup = etc/sysconfig/ganesha
source = nfs-ganesha-git::git://github.com/nfs-ganesha/nfs-ganesha.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f01605a5e9b4..9cc0c94022fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=nfs-ganesha-git
-pkgver=10720.437cb6711
+pkgver=11231.2e2b8e659
pkgrel=1
pkgdesc="Nfs-ganesha supports both the NFS and 9P protocols."
arch=('any')
@@ -12,6 +12,8 @@ makedepends=('git' 'cmake' 'gcc' 'bison' 'flex')
source=("$pkgname"::'git://github.com/nfs-ganesha/nfs-ganesha.git')
md5sums=('SKIP')
+backup=(etc/ganesha/ganesha.conf etc/sysconfig/ganesha)
+
pkgver() {
cd ${pkgname}
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
@@ -22,8 +24,19 @@ prepare() {
git submodule update --init
}
-package() {
+build() {
cd "${pkgname}"
- cmake src/ -DUSE_9P=OFF
- make
+ cmake src/ -DUSE_9P=OFF -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=/usr/lib
+ make
+}
+
+package() {
+ cd "${pkgname}"
+ make install DESTDIR="$pkgdir"
+ mv "$pkgdir"/var/run "$pkgdir"/run
+ rmdir "$pkgdir"/var
+ install -d "$pkgdir"/usr/lib/systemd/system "$pkgdir"/etc/sysconfig "$pkgdir"/usr/libexec/ganesha
+ install src/scripts/systemd/*.service "$pkgdir"/usr/lib/systemd/system
+ install src/scripts/systemd/sysconfig/nfs-ganesha "$pkgdir"/etc/sysconfig/ganesha
+ install src/scripts/nfs-ganesha-config.sh "$pkgdir"/usr/libexec/ganesha
}