summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhuoyun Wei2015-04-12 01:36:45 +0800
committerZhuoyun Wei2015-04-12 01:36:45 +0800
commit159ec0707063662d0ccb0e5fcd7f6d137e2f0609 (patch)
treeaf406c177676bada194983e9a0d400414d48a556
parentf0337664df9411ff1d4d73222191a1973e6873f6 (diff)
downloadaur-159ec0707063662d0ccb0e5fcd7f6d137e2f0609.tar.gz
[nghttp2] Add nghttpx.service
-rw-r--r--PKGBUILD9
-rw-r--r--nghttpx.service10
2 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 840bd8bec333..c423c3633df2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,17 @@
pkgname=nghttp2
pkgver=0.7.11
_pkgver=v0.7.11
-pkgrel=1
+pkgrel=2
pkgdesc="HTTP/2 C Library"
arch=('i686' 'x86_64')
url="https://nghttp2.org/"
license=('MIT')
depends=('openssl' 'libev' 'zlib' 'spdylay' 'libxml2' 'jansson' 'jemalloc')
-source=("https://github.com/tatsuhiro-t/nghttp2/releases/download/${_pkgver}/nghttp2-${pkgver}.tar.gz")
+source=("https://github.com/tatsuhiro-t/nghttp2/releases/download/${_pkgver}/nghttp2-${pkgver}.tar.gz"
+ "nghttpx.service")
backup=('etc/nghttpx/nghttpx.conf')
-sha256sums=('c3950bf9315de13dbbf4f2afbdf7e5e87a717700865516accc919d6bff8085a6')
+sha256sums=('c3950bf9315de13dbbf4f2afbdf7e5e87a717700865516accc919d6bff8085a6'
+ 'a8321410f7d97eb69583b3f7f847a223d9fa83eef3bdbc7ac059c1114ac687d9')
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -25,6 +27,7 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
+ install -Dm644 "$srcdir"/nghttpx.service "$pkgdir/usr/lib/systemd/system/nghttpx.service"
install -Dm644 nghttpx.conf.sample "$pkgdir/etc/nghttpx/nghttpx.conf"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/nghttp2/COPYING"
}
diff --git a/nghttpx.service b/nghttpx.service
new file mode 100644
index 000000000000..71367be4073c
--- /dev/null
+++ b/nghttpx.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=HTTP/2 experimental proxy
+After=network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/nghttpx --errorlog-syslog
+
+[Install]
+WantedBy=multi-user.target