summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Quinn2018-05-16 12:38:22 -0400
committerJoseph Quinn2018-05-16 12:38:22 -0400
commitb8b00a07b738dccf70d42f44f850f2b8bc909759 (patch)
tree3f945445147c202de544ef27b35fe39da7eb0c56
downloadaur-b8b00a07b738dccf70d42f44f850f2b8bc909759.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD25
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d34a8ef1856b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = nginx-h5bp-server-configs
+ pkgdesc = Nginx HTTP server boilerplate configs
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/h5bp/server-configs-nginx
+ arch = any
+ license = MIT
+ depends = nginx
+ provides = nginx-h5bp-server-configs
+ source = https://github.com/h5bp/server-configs-nginx/archive/2.0.0.tar.gz
+ sha1sums = 674b8084df61f72404ecedc2685c4267b7f17442
+
+pkgname = nginx-h5bp-server-configs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cce34ca5a919
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+# Created by https://www.gitignore.io/api/archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+LICENSE
+
+
+# End of https://www.gitignore.io/api/archlinuxpackages \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5a59cb5a030
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Joseph R. Quinn <quinn period josephr at protonmail dot com>
+pkgname=nginx-h5bp-server-configs
+_pkgname=server-configs-nginx
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="Nginx HTTP server boilerplate configs"
+arch=('any')
+url="https://github.com/h5bp/server-configs-nginx"
+license=('MIT')
+depends=('nginx')
+provides=("$pkgname")
+source=("https://github.com/h5bp/server-configs-nginx/archive/$pkgver.tar.gz")
+sha1sums=('674b8084df61f72404ecedc2685c4267b7f17442')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ rm h5bp/README.md
+}
+
+package() {
+ cd "$_pkgname-$pkgver"
+ install -d "$pkgdir/etc/nginx/"
+ mv h5bp "$pkgdir/etc/nginx/"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}