summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author46792015-12-05 10:50:33 +0800
committer46792015-12-05 10:50:33 +0800
commitb5fa0c05d118f6917ea8fe0386722bddf4a26b5f (patch)
tree19b956960ba82f8fd332098cec92f7c307f5d8d1
parentf518e6ac20a3f359895f559656b45548946c3f6a (diff)
downloadaur-b5fa0c05d118f6917ea8fe0386722bddf4a26b5f.tar.gz
fixes
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d7767dd3edc..a0e0169a6031 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -59,10 +59,10 @@ build() {
export CFLAGS="-Wno-error"
git clone https://boringssl.googlesource.com/boringssl
- cd boringssl
- mkdir build && cd build && cmake ../ && make && cd ../
+ cd ${srcdir}/boringssl
+ mkdir build && cd build && cmake ../ && make && cd ${srcdir}/boringssl
mkdir -p .openssl/lib && cd .openssl && ln -s ../include . && cd ../
- cp build/crypto/libcrypto.a build/ssl/libssl.a .openssl/lib && cd ..
+ cp ${srcdir}/boringssl/build/crypto/libcrypto.a ${srcdir}/boringssl/build/ssl/libssl.a .openssl/lib && cd ..
cd $_src_dir
@@ -92,7 +92,7 @@ build() {
--with-pcre-jit \
--with-stream
- touch ../boringssl/.openssl/include/openssl/ssl.h
+ touch ${srcdir}/boringssl/.openssl/include/openssl/ssl.h
patch -p0 < ../openssl.patch
make